If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Upload file from clipboard with Ctrl-v

REOPENED
Unassigned

Status

()

Core
Layout: Form Controls
--
enhancement
REOPENED
3 years ago
2 years ago

People

(Reporter: Alexandro, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; CrOS x86_64 5978.98.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36

Steps to reproduce:

Select a file on a file manager, select Edit -> Copy or Ctrl-c. 
Move to the browser input field, and type Ctrl-v.


Actual results:

Nothing


Expected results:

Upload the file on the clipboard.
(Reporter)

Comment 1

3 years ago
Further explanation of the feature request:
http://alexandrocolorado.com/2014/10/22/put-ctrl-v-on-the-web/
Points: --- → 3
Component: Untriaged → File Handling
OS: Other → All
Priority: -- → P3
Hardware: x86_64 → All

Comment 2

3 years ago
It's already the case, see http://imgur.com/ (click on "upload images"), you can upload images from the clipboard.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Points: 3 → ---
Last Resolved: 3 years ago
Component: File Handling → Untriaged
Priority: P3 → --
Resolution: --- → WORKSFORME
That's not the same, because it requires explicit website support. It's great that websites can support this if they want to, but I want to be able to upload file contents from the clipboard (and files from the file system that I've Ctrl-Ced) even if the website doesn't explicitly support it. So it needs browser help. Both Ctrl-V when the file input control is focussed, and also a right-click menu item on the control "Upload from Clipboard".

Gerv
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---

Updated

2 years ago
Severity: normal → enhancement
Component: Untriaged → HTML: Form Submission
Product: Firefox → Core

Updated

2 years ago
Component: HTML: Form Submission → Layout: Form Controls
You need to log in before you can comment on or make changes to this bug.