Gaia built with PRODUCTION=1 does not boot on Mulet, device

RESOLVED FIXED

Status

Firefox OS
Gaia::Build
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gerard, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
STR:
 0. Build Gaia with PRODUCTION=1
 1. Start in mulet, or boot your device

Expected:
 Gaia boots

Actual:
 System app does not seems to be loading.
(Reporter)

Comment 1

4 years ago
Doing a local revert of bug 969215 makes my Mulet happy.
Depends on: 969215
(Reporter)

Comment 2

4 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #1)
> Doing a local revert of bug 969215 makes my Mulet happy.

Re-applying the patch, doing a make clean really-clean, regenerating a production profile, my mulet starts.
(Reporter)

Comment 3

4 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #2)
> (In reply to Alexandre LISSY :gerard-majax from comment #1)
> > Doing a local revert of bug 969215 makes my Mulet happy.
> 
> Re-applying the patch, doing a make clean really-clean, regenerating a
> production profile, my mulet starts.

And I can confirm I have to backout this otherwise my device does not boot anymore. It looks like:
 - make clean
 - build.sh && flash.sh

Works a first time. But subsequent tries will fail.
Flags: needinfo?(ricky060709)
(Reporter)

Comment 4

4 years ago
> $ cat profile/webapps/webapps.json 
> {}

That will not help :)
yeah, it's a regression since we didn't regenerate correct webapps.json. Mark as duplicate.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ricky060709)
Resolution: --- → DUPLICATE
Duplicate of bug: 969215
(Reporter)

Comment 6

4 years ago
(In reply to Ricky Chien [:rickychien] from comment #5)
> yeah, it's a regression since we didn't regenerate correct webapps.json.
> Mark as duplicate.
> 
> *** This bug has been marked as a duplicate of bug 969215 ***

That's not a dupe. Backout of bug 969215 fixed it.
blocking-b2g: 2.2? → ---
Resolution: DUPLICATE → FIXED
You need to log in before you can comment on or make changes to this bug.