All users were logged out of Bugzilla on October 13th, 2018

Blocks with writing-mode vertical-rl disappear to the right

RESOLVED DUPLICATE of bug 1088025

Status

()

RESOLVED DUPLICATE of bug 1088025
4 years ago
4 years ago

People

(Reporter: smontagu, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8510434 [details] [diff] [review]
Testcase (based on the test for bug 1083892)

With the fix for bug 1083892 there is still a problem with vertical-rl - the inner paragraph disappears completely over the horizon. Debugging shows that logical/physical coordinate conversions are using NS_UNCONSTRAINEDSIZE as container width.
(Reporter)

Comment 1

4 years ago
Created attachment 8510441 [details]
Testcase (based on the test for bug 1083892)
Attachment #8510434 - Attachment is obsolete: true
I just filed this as bug 1088025. :) I don't have a patch yet, though...
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1088025
(Reporter)

Comment 3

4 years ago
Created attachment 8510447 [details] [diff] [review]
Tentative patch

This is more a POC than a real patch. With it the paragraph in the testcase is visible, but still displayed too far to the right. That may well be a different bug, though.
Attachment #8510447 - Flags: feedback?(jfkthame)
Comment on attachment 8510447 [details] [diff] [review]
Tentative patch

Cancelling f? here, this has been duped to bug 1088025 (note that the "part 1" patch there is virtually equivalent to this).
Attachment #8510447 - Flags: feedback?(jfkthame)
You need to log in before you can comment on or make changes to this bug.