Context menu's "Open link in new tab", and toolbar's search field do not work (no search engines in the latter)

RESOLVED DUPLICATE of bug 438599

Status

()

defect
RESOLVED DUPLICATE of bug 438599
5 years ago
2 years ago

People

(Reporter: ronshere, Unassigned)

Tracking

33 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Opera/9.80 (X11; Linux x86_64; Edition Linux Mint) Presto/2.12.388 Version/12.16

Steps to reproduce:

I cannot open a new tab when i click or right click to choose from the menu
to open in a new tab, nothing works.
Also there are no search engines and cannot ad a search engine.
I have tried tried safe mode and it did not fix it.
I have tried a new profile and that does not work.
I have completely uninstalled several times and it does not help.
I am using Linux 17 Mint 64 bit Mate edition
Application Basics
------------------

Name: Firefox
Version: 33.0
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Multiprocess Windows: 0/1

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Ubuntu Firefox Modifications
Version: 2.9
Enabled: false
ID: ubufox@ubuntu.com

Graphics
--------

Adapter Description: X.Org -- Gallium 0.4 on AMD RS880
Device ID: Gallium 0.4 on AMD RS880
Driver Version: 3.0 Mesa 10.1.0
GPU Accelerated Windows: 0/1 Basic
Vendor ID: X.Org
WebGL Renderer: X.Org -- Gallium 0.4 on AMD RS880
windowLayerManagerRemote: false
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0

Comment 1

5 years ago
That's pretty awful. Where are you installing Firefox from? Can you try using an official release from https://www.mozilla.org/firefox/ instead of whatever ships with Linux Mint? If that doesn't help, how about creating a clean profile with that release? ( https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles )
Flags: needinfo?(ronshere)

Comment 2

5 years ago
Somebody else has had a problem with Firefox 31 and Iceweasel on Debian stable, which he said was like https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725292, and got it fixed by something like this:
1. Start with a new profile (it did not work).
2. Restart with that profile (it worked).
3. Copy search.json from that new profile over the one in the broken profile.

Comment 3

5 years ago
I can confirm that same behaviour, including the last post. It just happened again to me on Debian/stable wih the upgrade from 31.2.0esr-2 to 31.2.0esr-3~deb7u1.

The most important thing I can see: I have disabled search engine updates under Settings.
Comment hidden (obsolete)

Comment 5

5 years ago
(In reply to Elrond from comment #3)
> I can confirm that same behaviour, including the last post. It just happened
> again to me on Debian/stable wih the upgrade from 31.2.0esr-2 to
> 31.2.0esr-3~deb7u1.
> 
> The most important thing I can see: I have disabled search engine updates
> under Settings.

How is open in new tab affected? Do you see any errors in the error console when you use it? That part doesn't sound related to search at all. (although it could still be, of course... software is a strange place sometimes :-) )
Flags: needinfo?(elrond+bugzilla.mozilla.org)

Comment 6

5 years ago
Open in New Tab is affected as described: Just does nothing.

The relation to search is simple: If I copy a fresh search.json over, everything is nice and good.

Checking the error console means breaking my main installation. I think, I can do that by just deleting search.json. I'll hopefully try soon.
Flags: needinfo?(elrond+bugzilla.mozilla.org)

Comment 7

5 years ago
Okay, removing search.json nicely reproduces things for me.

And really, the error console has something, when trying Open in New Tab from contectmenu:

> NS_ERROR_FAILURE: Failure'Failure' when calling method: [nsIBrowserSearchService::currentEngine] nsContextMenu.js:1668`
> TypeError: gContextMenu is null overlay.js:410
> gContextMenu is null refcontrolOverlay.js:149
> RefControl: TypeError: gContextMenu is null
> onPopupShowing@chrome://refcontrol/content/refcontrolOverlay.js:149:6
> handleEvent@chrome://refcontrol/content/refcontrolOverlay.js:174:6
> 
> TypeError: gContextMenu is null browser.xul:1

Comment 8

5 years ago
Drew, second time today, sorry... but do you know what's going on here? :-)
Component: Untriaged → Search
Flags: needinfo?(ronshere)
No, sorry.  Comment 7 sounds like we have a simple step to reproduce (remove search.json from your profile and start Firefox?), so it shouldn't be too hard to find what the problem is.

Comment 10

4 years ago
This still affects me on 38.2.1esr on Debian/stable/32bit. Now it's at the point, that even creating a new profile exhibits this problem. I have no idea, what is so special about my install.

Interesting next fact: If I go to the preferences and then click on "Search", nothing happens, but in the Browser Console I get these three entries:

  uncaught exception: 2147500037 <unknown>
  Error initializing preference category paneSearch: [Exception... "Failure'Failure' when calling method: [nsIBrowserSearchService::getVisibleEngines]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/preferences/in-content/search.js :: EngineStore :: line 270"  data: no] preferences.js:131:0
  NS_ERROR_FAILURE: Failure'Failure' when calling method: [nsIBrowserSearchService::getVisibleEngines] search.js:270:0

Could someone please investigate, how these could happen?

Comment 11

4 years ago
Okay, next interesting bit:

If I remove /etc/iceweasel/searchplugins/ (so that there are no search plugins at all), then some things work better. Especially pressing <Return> in the URLbar works again, which makes Firefox a lot more usable.

Updated

4 years ago
Flags: needinfo?(gijskruitbosch+bugs)

Comment 12

4 years ago
(In reply to Drew Willcoxon :adw from comment #9)
> No, sorry.  Comment 7 sounds like we have a simple step to reproduce (remove
> search.json from your profile and start Firefox?), so it shouldn't be too
> hard to find what the problem is.

This doesn't reproduce the issue for me, at least not on OS X with current trunk. search.json just gets regenerated.

I'm not really sure where to go from here, and barring more information about how this happens, sadly I also don't think I can justify spending a lot of time investigating this further as it is unclear how that file disappears and why it doesn't just get regenerated. Elrond, can you reproduce this with something more recent than ESR 38?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(elrond+bugzilla.mozilla.org)

Comment 13

4 years ago
I am quite unsure, what is so special about this machine. I already analyzed strace for specific syscalls that the kernel on this system might not support. But adding quotactl() to the next kernel recompile did not change anything.

That said, I am not really easily able to run anything not in Debian/stable on this machine.

Two points:

1. I have posted multiple errors from the browser console. They seem to be very related. What do they mean? How could those errors happen? Could more error reporting be added for any upcoming esr to track those errors more down?

2. The original reporter could also be asked to retry with a current version? (Just set the flag)
Flags: needinfo?(elrond+bugzilla.mozilla.org) → needinfo?(ronshere)

Comment 14

4 years ago
(In reply to Elrond from comment #13)
> I am quite unsure, what is so special about this machine. I already analyzed
> strace for specific syscalls that the kernel on this system might not
> support. But adding quotactl() to the next kernel recompile did not change
> anything.
> 
> That said, I am not really easily able to run anything not in Debian/stable
> on this machine.

You can recompile the kernel, but not run a binary downloaded off mozilla.org ?

> Two points:
> 
> 1. I have posted multiple errors from the browser console. They seem to be
> very related. What do they mean? How could those errors happen?

NS_ERROR_FAILURE could be pretty much anything. It looks like initializing the search component fails, but goodness knows why.

> Could more
> error reporting be added for any upcoming esr to track those errors more
> down?

Without an indication that this is prevalent and/or still happens on current versions of Firefox, that is not likely to happen.


From looking quickly at the initialization of the search component and given comment #11, and that this is a linux distro so there might be broken searchplugins in that directory? Any chance you could binary search (delete half, try, delete other half, etc.) to figure out which searchplugin is triggering the brokenness? That might help in reproducing this.
Flags: needinfo?(elrond+bugzilla.mozilla.org)

Comment 15

4 years ago
(In reply to :Gijs Kruitbosch from comment #14)
> You can recompile the kernel, but not run a binary downloaded off
> mozilla.org ?

Right, complex policy. It's one of my devel boxes.

[...]
> From looking quickly at the initialization of the search component and given
> comment #11, and that this is a linux distro so there might be broken
> searchplugins in that directory? Any chance you could binary search (delete
> half, try, delete other half, etc.) to figure out which searchplugin is
> triggering the brokenness? That might help in reproducing this.

Yes, I can try that. Will take a bit of time.

Note that having no searchplugins at all still leaves Context menus Open in New Tab broken. I can workaround that in various ways, but it's still no fun.
The 'no search engine available' case should no longer be possible now that bug 438599 is fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 438599
Flags: needinfo?(ronshere)
Flags: needinfo?(elrond+bugzilla.mozilla.org)
You need to log in before you can comment on or make changes to this bug.