Closed Bug 1088754 Opened 8 years ago Closed 8 years ago

[Messages] No overlay while deleting

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-b2g:-, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1084252
blocking-b2g -
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: julienw, Unassigned)

References

Details

(Keywords: regression)

STR:
1. be sure you have some threads in the Messages app
2. start the Messages app
3. press the "settings" button and start "select threads" mode
4. press "select all"
5. press "delete"

Expected:
* we should have an overlay with a spinner while deleting

Actual:
* we have nothing while it's deleting

Happening on latest master v2.2 on Flame (v188).

QA: please check on v2.0 and v2.1 and find a regression window.
Tested with Shallow Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.2 KK

Actual Results: No deleting message with spinning icon seen when deleting threads.

Repro Rate: 2/2

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141024070214
Gaia: 29ed78a26d62b58f663437a45f273d57b9781d79
Gecko: d6abb9bf43be
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, Flame 2.0 KK

Actual Result: Deleting threads correctly shows deleting message with spinning icon.

Repro Rate: 0/4

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141024091117
Gaia: 07cd1562b90960a343104a67b184cf9e01bee8a0
Gecko: b4770afd8692
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141024064809
Gaia: 1a89b5317dbc31da9c604d677a4a5a3e34122a17
Gecko: cfa7cdcb728b
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: croesch
NI SMS owner for blocking call
Flags: needinfo?(echang)
2.2? already added, regression..
Flags: needinfo?(echang)
QA Contact: jmercado
Could be a regression from bug 1078295
Bug 1078295 is in the pushlog for the regression window as Julien suggested.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141015070318
Gaia: a18559e844b6aec946309a3bee6a32ca06ab4649
Gecko: fe4916e0e9df
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141015102818
Gaia: 93fb5070782a549977cf8c485c5d93de54ec657e
Gecko: 069db53e0f68
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: a18559e844b6aec946309a3bee6a32ca06ab4649
Gecko: 069db53e0f68

First Broken gaia / Last Working gekko - Issue DOES occur
Gaia: 93fb5070782a549977cf8c485c5d93de54ec657e
Gecko: fe4916e0e9df

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/a18559e844b6aec946309a3bee6a32ca06ab4649...93fb5070782a549977cf8c485c5d93de54ec657e
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Pushlog agrees with comment 4 - broken by bug 1078295 - can you take a look Chris?
Blocks: 1078295
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(chrislord.net)
QA Contact: jmercado
Possible dupe to bug 1084252
Depends on: 1084252
(In reply to Julien Wajsberg [:julienw] from comment #7)
> Possible dupe to bug 1084252

I just checked the patch and it's dupe indeed.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1084252
removing nom as it's the dup is 2.2+ already
blocking-b2g: 2.2? → -
Flags: needinfo?(chrislord.net)
You need to log in before you can comment on or make changes to this bug.