[Camera] Camera app performance deteriorates when taking pictures, leading to app closure.

VERIFIED FIXED in 2.1 S8 (7Nov)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Marty, Assigned: aosmond)

Tracking

({regression})

unspecified
2.1 S8 (7Nov)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-Daily-Testing], )

Attachments

(2 attachments)

Reporter

Description

5 years ago
Posted file Camera-log.txt
Description:
On a fresh boot of the DUT, the camera app performance will deteriorate with each picture taken.  After about 10-12 pictures, the camera app will close out in what appears to be an LMK or possibly OOM crash.

Additionally, if the camera app is relaunched after this happens, the performance will be significantly worse, and the camera will close out after 3-4 pictures.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141024040202
2) Open the Camera app
3) Attempt to take 15 snapshots
4) Note the performance as you take snapshots.
  
Actual:
Camera app performance deteriorates with use, resulting in app closure.
  
Expected: 
Camera performance remains consistent when using the Camera app, and does not result in app closure.
  
Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141024040202 (Full Flash)
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
  
Notes: This issue does not seem to occur on 512MB memory.
  
Repro frequency: 5/5
See attached: logcat

------------

This issue does NOT occur on Flame 2.1.
Camera performance remains consistent when using the Camera app, and does not result in app closure.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Reporter

Comment 1

5 years ago
Posted file Camera2-log.txt
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Reporter

Comment 2

5 years ago
Adding a video to demonstrate the issue.
Nominating for block in 2.2. 
Bad UX, application will eventually close and return user to home while performing expected functionality.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regression
Assignee

Comment 4

5 years ago
I can't even get it to show the preview after relaunching, once the initial OOM death occurs. This seems to be in spite of the fact that the free memory levels are similar before and after.
Assignee

Updated

5 years ago
Assignee: nobody → aosmond
QA Contact: pcheng
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141029061211
Gaia: a9a847920b51b79c4ad4ad339f0a005777a6228c
Gecko: 42da94fcdfd9
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141029071617
Gaia: a9a847920b51b79c4ad4ad339f0a005777a6228c
Gecko: 703cf7b92df4
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=42da94fcdfd9&tochange=703cf7b92df4
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)

Comment 6

5 years ago
Reason for blocking: Camera's performance degrades and eventually camera app closes down in about 10 continuous shots that are not too close apart from each other. Regression.
blocking-b2g: 2.2? → 2.2+
Target Milestone: --- → 2.1 S8 (7Nov)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: pcheng
Assignee

Updated

5 years ago
Depends on: 1077301
Assignee

Comment 7

5 years ago
Graphics change in bug 1077301 appears to have introduced the problem.
No longer depends on: 1077301
Assignee

Comment 8

5 years ago
Err readd dependency removed by mistake.
Depends on: 1077301
Assignee

Comment 9

5 years ago
Fixed in the latest builds now.

https://hg.mozilla.org/mozilla-central/rev/66be6ec6d514
https://hg.mozilla.org/integration/mozilla-inbound/rev/66be6ec6d514
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 10

5 years ago
Verified the issue is fixed on 2.2 Flame 

Camera app performance is no longer deteriorate when taking pictures
Made 15 pictures it didn't slow performance of the "Camera" app

"Flame 2.2
Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.