All users were logged out of Bugzilla on October 13th, 2018

[Settings]Languages that are right aligned will cause the status bar icons to overlap the rocket bar in the settings app

RESOLVED DUPLICATE of bug 1059379

Status

RESOLVED DUPLICATE of bug 1059379
4 years ago
4 years ago

People

(Reporter: cnelson, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-Exploratory-3])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8511273 [details]
logcat.txt

When the user changes their language to any of the languages that are right aligned, the status bar icons will overlap the rocket bar in the settings app.  See attached screen shot for a visual aid.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141024001204
2) Change the devices language to any language that is right aligned (Arabic, Hebrew, URDU).
3) Notice the status bar icons overlap the rocket bar.

  
Actual:
The status bar icons overlap the rocket bar when set to any language that is right aligned.
  
Expected: 
The status bar icons will never overlap the rocket bar.
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 100%
See attached: screenshot, logcat
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
Created attachment 8511275 [details]
2014-10-24-13-01-04.png
(Reporter)

Comment 2

4 years ago
This issue doesn't occur on Flame Master (319mb)(KitKat Base)(FullFlash), and Flame 2.0  (319mb)(Kitkat Base)(Full Flash)

The status bar icons will never overlap the rocket bar.

Flame 2.2

Environmental Variables:
Device: Flame Master (319mb)(KitKat Base)(FullFlash)
Build ID: 20141024040202
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.0

Environmental Variables:
Device: Flame 2.0  (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141024000201
Gaia: 86d83f4b4111ca45ebc92ca779348cc966f43cff
Gecko: f8432250efb7
Version: 32.0 (2.0)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
(Reporter)

Updated

4 years ago
Component: Gaia::Settings → Gaia::System::Window Mgmt
Seems like the same as bug 1059379
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Resolution: --- → DUPLICATE
Duplicate of bug: 1059379
You need to log in before you can comment on or make changes to this bug.