WebRTC client's video capture has squished aspect ratio and gray padding on left and right edges

RESOLVED DUPLICATE of bug 1094539

Status

()

RESOLVED DUPLICATE of bug 1094539
4 years ago
4 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression, reproducible})

unspecified
x86
Mac OS X
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox33 unaffected, firefox34 unaffected, firefox35 affected, firefox36 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8511487 [details]
good.jpg

When using the Hello WebRTC client, the video captured (self-view and sent video) has a squished aspect ratio and gray padding on the left and right edges. See the circled areas on the attached screenshots. I am running OS X 10.10 (Yosemite) on a MacBook Pro with a HiDPI Retina display.

I bisected this regression to MediaEngine bug 1053130.
(Reporter)

Comment 1

4 years ago
Created attachment 8511488 [details]
bad.jpg
(Reporter)

Comment 2

4 years ago
[Tracking Requested - why for this release]:

This bug is a WebRTC video regression in Firefox 35, visible to both "Hello" client senders and receivers.
tracking-firefox35: --- → ?
Will track since it's a new regression - ni? on Alfredo to investigate backing out or doing a forward fix of the regressing bug.
tracking-firefox35: ? → +
tracking-firefox36: --- → +
Flags: needinfo?(ayang)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ayang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1094539
tracking-firefox35: + → ---
tracking-firefox36: + → ---
You need to log in before you can comment on or make changes to this bug.