If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Gap below Loop panel footer due to min-height

RESOLVED WORKSFORME

Status

Hello (Loop)
Client
P3
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Sören Hentzschel, Unassigned, Mentored)

Tracking

unspecified
All
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox35 affected, firefox36 affected)

Details

(Whiteboard: [lang=js][good first bug])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8511546 [details]
screenshot.png

Please see the screenshot.

OS X 10.10 w/ HiDPI display, Firefox Nightly 2014-10-25.
The reason for that is that the panel now is even smaller. We have to decrease the number in http://hg.mozilla.org/mozilla-central/file/f2d7d694aae5/browser/modules/Social.jsm#l17 even more. In fact, we should even decrease it to some super-small universal value. And if a panel wants to be high then it should make it high by setting the height of the html inside of it. So the patch is as simple as changing that value (unless changing it breaks some other panel).

I'm not sure if this bug should really be set as blocking for bug 1069028. Especially because that bug is now fixed (and it got broken again).
Sören, in the future, could you make the bug summary more specific please.

I think we should just lower the minimum to what Loop needs again unless mixedpuppy wants to write the patch since he knows more about the Social uses of this panel.

Follow-up bugs block the bug that caused/exposed it and bug 1069028 is what exposed this problem so this link is fine.
Summary: Loop panel footer style issue → Gap below Loop panel footer due to min-height
This gives a bad first impression in Hello primary UI and is trivial to fix so I think we should do it. We can just bump the number from http://hg.mozilla.org/mozilla-central/file/f2d7d694aae5/browser/modules/Social.jsm#l17 down the minimal amount (to avoid risk).
Mentor: MattN+bmo@mozilla.com
backlog: --- → Fx35?
status-firefox35: --- → affected
status-firefox36: --- → affected
Whiteboard: [lang=js]
Whiteboard: [lang=js] → [lang=js][good first bug]

Comment 4

3 years ago
validate if 10/24 is before the footerbug landed - check it out.
Flags: needinfo?(sescalante)
backlog: Fx35? → Fx35+
Priority: -- → P2
Duplicate of this bug: 1106010

Updated

3 years ago
backlog: Fx35+ → Fx36+
Moving P2->P3 (P3 is a "normal" bug that we want fixed for Fx36.)
Priority: P2 → P3
backlog: Fx36+ → Fx38?
I believe this is fine from 37 onwards - there's still possibly a small line in 35/36.

I'm going to mark as WFM, if anyone thinks there's still an issue, please feel free to re-open and attach a screenshot.
Status: NEW → RESOLVED
backlog: Fx38? → ---
Last Resolved: 3 years ago
Flags: needinfo?(sescalante)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.