Closed Bug 1089198 Opened 5 years ago Closed 5 years ago

Tap on message report header, the contextual menu "…" will be shown

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:-, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED FIXED
2.1 S8 (7Nov)
blocking-b2g -
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: tchevalier, Assigned: wilsonpage)

References

Details

(Keywords: regression, Whiteboard: [p=1])

Attachments

(2 files)

Attached image Flame 2.2
Might be a dupe, but filing just in case.

STR:
1. send or receive a message
2. Long tap on message, select "View report"
3. Tap on "Message report" text in header

Actual result:
"…" is displayed while you're tapping on it, and you can even trigger the menu.

Expected result:
Nothing happens
I don't think it's a dupe, thanks a lot Théo !

QA: can you check on various branches? Thanks!
blocking-b2g: --- → 2.2?
Keywords: qawanted
I believe it's a regression.
Cannot reproduce on 2.1, but able on 2.2. (Both tests done on Flame, base v188)
Likely a regression from bug 1021608
Blocks: 1021608
Tested with Shallow Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.2 KK

Actual Results: Tapping on the Message Report header causes an ellipsis icon to show briefly where the user can access a menu.

Repro Rate: 2/2

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141026103710
Gaia: e91d99e4d96954f06383c00bb9d79598a697e310
Gecko: 8230834302c9
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, Flame 2.0 KK

Actual Result: Tapping on the Message Report header does not cause an ellipsis to appear.

Repro Rate: 0/4

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141027032141
Gaia: f8378fe1c7f128a3b679201b469a82fca2371828
Gecko: 32a102b8e807
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141026145711
Gaia: 2183b4f3ec0eb47ab1f133c31732ec53b08ad253
Gecko: 43bee45176c4
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
QA Contact: croesch
QA-Wanted: Regression-window wanted to verify comment 3
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: croesch
QA Contact: pcheng
(In reply to Joshua Mitchell [:Joshua_M] from comment #5)
> QA-Wanted: Regression-window wanted to verify comment 3

The fix for bug 1021608, which was suggested at comment 3, is NOT the cause of the bug.

-----

b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141010023807
Gaia: cc5da7b055e2b06fdeb46fa94970550392ee571d
Gecko: 4bb49c594257
Version: 35.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141010030807
Gaia: ccaa914af0e77063866f18820d55c4506d3fb581
Gecko: 68070e4a6d9a
Version: 35.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Gaia Last Working Gecko - issue DOES repro
Gaia: ccaa914af0e77063866f18820d55c4506d3fb581
Gecko: 4bb49c594257

First Broken Gecko Last Working Gaia - issue does NOT repro
Gaia: cc5da7b055e2b06fdeb46fa94970550392ee571d
Gecko: 68070e4a6d9a

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/cc5da7b055e2b06fdeb46fa94970550392ee571d...ccaa914af0e77063866f18820d55c4506d3fb581

Caused by Bug 1076907.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Caused by Bug 1076907 - can you take a look
Blocks: 1076907
No longer blocks: 1021608
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(wilsonpage)
QA Contact: pcheng
Whiteboard: [p=1]
Target Milestone: --- → 2.1 S8 (7Nov)
Attached file pull-request (master)
REASON

- gaia-header adds classes to ancestors when pressed, this was breaking the fragile [class$=information] selector, which will only match if the entire class attribute value ends in 'information'.
- This is a simple fix for SMS. But I have also changed the gaia-header classList behaviour to prevent classes being added out of scope of the component. This will land in Gaia when we next update the component.
Flags: needinfo?(wilsonpage)
Attachment #8512603 - Flags: review?(felash)
Remove from sprint because Wilson has a patch.
Assignee: nobody → wilsonpage
No longer blocks: sms-sprint-2.1S8
(In reply to Wilson Page [:wilsonpage] from comment #8)
> Created attachment 8512603 [details] [review]
> pull-request (master)
> 
> REASON
> 
> - gaia-header adds classes to ancestors when pressed, this was breaking the
> fragile [class$=information] selector, which will only match if the entire
> class attribute value ends in 'information'.
> - This is a simple fix for SMS. But I have also changed the gaia-header
> classList behaviour to prevent classes being added out of scope of the
> component. This will land in Gaia when we next update the component.

This whole CSS rule is actually completely wrong, we should update it. But let's fix the regression first, thanks for the patch!
Comment on attachment 8512603 [details] [review]
pull-request (master)

r=me with "information" changed in "-information"
Attachment #8512603 - Flags: review?(felash) → review+
master: 30e37915865af8eb8164a50e7512e68f40967961

thanks !
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Note: we have bug 961572 about having a separate header for the information panel. Hopefully we'll be able to do it at one point :/
removing nom as it's already fixed on master (2.2).
blocking-b2g: 2.2? → -
You need to log in before you can comment on or make changes to this bug.