"ICE Contacts" in contacts list is hardcoded

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: tchevalier, Assigned: tchevalier)

Tracking

unspecified
2.1 S8 (7Nov)
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(3 attachments)

"ICE Contacts" displayed in the main view of Contacts app is hardcoded.

It's displayed when user sets ICE Contacts from Contacts settings.

I propose we add a new string for 2.2 and reuse ICE Contacts string from Settings header for 2.1. Reusing strings is bad, but it's still better than having the first contact in English for all locales.

[Blocking Requested - why for this release]:
We have a quite visible hardcoded string in the UI, and a trivial fix to bypass it, without breaking the string freeze.
Created attachment 8511558 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25515

Fix for master only
Attachment #8511558 - Flags: review?(jmcf)
Created attachment 8511565 [details]
Screenshot, Flame 2.2 (de)
Created attachment 8511566 [details] [review]
[2.1] Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25516

PR for 2.1 branch only

Both patches tested on Flame 2.2
Attachment #8511566 - Flags: review?(jmcf)
triage: ICE contact is major new feature for 2.1
blocking-b2g: 2.1? → 2.1+

Comment 5

4 years ago
Comment on attachment 8511558 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25515

please address comments on GH
Attachment #8511558 - Flags: review?(jmcf)

Updated

4 years ago
Attachment #8511566 - Flags: review?(jmcf)
Comment on attachment 8511558 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25515

Thanks for the feedback, addressed your comments on both patches.
Would you mind giving it another look? :)

Thanks!
Attachment #8511558 - Flags: review?(jmcf)
Attachment #8511566 - Flags: review?(jmcf)

Comment 7

4 years ago
Comment on attachment 8511558 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25515

thanks Theo
Attachment #8511558 - Flags: review?(jmcf) → review+

Comment 8

4 years ago
Comment on attachment 8511566 [details] [review]
[2.1] Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25516

thanks. good idea to reuse that string
Attachment #8511566 - Flags: review?(jmcf) → review+
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/2ffcbac5489f4943300e57f4d7b711bc4a1db5ab
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8511566 [details] [review]
[2.1] Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25516

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Feature ice contacts
[User impact] if declined:
Bad user experience with untranslated string
[Testing completed]:
Smoke tests on the device
[Risk to taking this patch] (and alternatives if risky):
Low, just using mozl10n
[String changes made]:
No, despite is a problem with translation, we had the translation but we were not using it
Attachment #8511566 - Flags: approval-gaia-v2.1?(bbajaj)

Updated

4 years ago
Attachment #8511566 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.1 S8 (7Nov)
That's really embarrassing, I forgot a semicolon in a one liner patch… Sorry guys, just fixed the PR.
Flags: needinfo?(tchevalier)
Keywords: verifyme
This issue is verified fixed on Flame 2.1.

Result: "ICE Contacts" string is translated on the main screen and settings page on Contacts app when the language is set to German. 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141104001202
Gaia: 8b0cf889ae0d48a9eb7ecdcb9b67590de45cc5e5
Gecko: 388b03efe92d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
=============================================

This issue still reproduces on Flame 2.2.

Result: "ICE Contacts" string is translated on the settings page on Contacts app, but NOT on the main screen when the language is set to German. (Same as the screenshot on Comment 2)

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141104040207
Gaia: 3c50520982560ccba301474d1ac43706138fc851
Gecko: 54d05732f29b
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?][failed-verification]
status-b2g-v2.1: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
Hi,

Could you please check again master with pseudo-locale (Accented English) or Italian, please?

A different string is used on master, and it's not translated in German yet: http://transvision.mozfr.org/?recherche=apps%2Fcommunications%2Fcontacts%2Fcontacts.properties%3AICEContactsGroup&repo=gaia&sourcelocale=en-US&locale=de&search_type=entities

See the locales that translated this string: http://transvision.mozfr.org/string/?entity=apps/communications/contacts/contacts.properties:ICEContactsGroup&repo=gaia

Thanks!
Flags: needinfo?(ychung)
Hi Theo,

Thanks for the clarification. I checked with Italian and Danish, and they are both translated on master. I'll change the status to "verified" for 2.2.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ychung)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.