%label of "Zoom Widget" indicates previous zoom level when If you have multiple browser windows open

VERIFIED FIXED in Firefox 54

Status

()

VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: alice0775, Unassigned)

Tracking

({reproducible, ux-userfeedback})

Trunk
Firefox 55
reproducible, ux-userfeedback
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox33 wontfix, firefox34 affected, firefox35 affected, firefox36 affected, firefox37 affected, firefox38 affected, firefox39 affected, firefox49 wontfix, firefox-esr31 wontfix, firefox-esr38 wontfix, firefox-esr45 wontfix, firefox50 affected, firefox51 wontfix, firefox52 fix-optional, firefox53+ wontfix, firefox54+ verified, firefox55 verified)

Details

(Whiteboard: fixed by bug 1345375)

(Reporter)

Description

4 years ago
Steps To Reproduce:
1.Move zoom widget button on Tabbar
2.Open 2 browser window
3.Open same page in these browser window
4.Zoom in/out 

Actual Results:
Content is zoomed as expected.
However,%label of the Zoom Widget indicates previous zoom level on the other browser window

Expected Results:
%label of the Zoom Widget should be synchronized.
(Reporter)

Updated

4 years ago
Keywords: ux-userfeedback
I can't reproduce this on Mac - flagging qawanted to see if we can get some more info on if this is limited to certain platforms.
Keywords: qawanted
(Reporter)

Comment 2

4 years ago
This is also reproduced on Ubuntu.
OS: Windows 7 → All
(Reporter)

Comment 3

4 years ago
This problem appears since Nightly(2013-Nov-18 Australis merge day)


Regression window(ux)
Good(not indicated %label if zoom widget is placed in toolbar):
http://hg.mozilla.org/projects/ux/rev/3b44793578f6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131018040212
Bad(indicated %label, and reproduce the problem):
http://hg.mozilla.org/projects/ux/rev/dd567c98f03e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131019040202
Pushlog:
http://hg.mozilla.org/projects/ux/pushloghtml?fromchange=3b44793578f6&tochange=dd567c98f03e
Blocks: 869933
Given that we've shipped 7 releases with this bug without any major complaints, I'm not going to track. I have nomed this for the Firefox backlog.
status-firefox33: affected → wontfix
status-firefox-esr31: affected → wontfix
tracking-firefox34: ? → ---
tracking-firefox35: ? → ---
tracking-firefox36: ? → ---
tracking-firefox-esr31: ? → ---
Flags: firefox-backlog?

Updated

4 years ago
Flags: firefox-backlog? → firefox-backlog+
(Reporter)

Updated

4 years ago
status-firefox37: --- → affected
(Reporter)

Updated

4 years ago
status-firefox38: --- → affected
status-firefox39: --- → affected
status-firefox-esr38: --- → affected
(Reporter)

Updated

2 years ago
status-firefox49: --- → wontfix
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox-esr38: affected → wontfix
status-firefox-esr45: --- → wontfix
(Reporter)

Comment 5

2 years ago
The problem is worsened along with the landing landing of Bug 565718.
The problems became noticeable.
Blocks: 565718
(Reporter)

Updated

2 years ago
See Also: → bug 1313863
(Reporter)

Comment 6

2 years ago
Altenate Steps To Reproduce:
2.Open 2 browser window
3.Open same page in these browser window
4.Zoom in/out in a browser window
  --- Observe, zoom level in location bar in the other browser window

Actual Results:
The Zoom level indicated previous level though contents is zoomed correctly

Expected Results:
The Zoom level should be synced between contents and indicator
Whiteboard: [qawanted, reproduce, bad product reliability]
(Reporter)

Updated

2 years ago
See Also: bug 1313863
(Reporter)

Updated

2 years ago
See Also: → bug 1331033
[Tracking Requested - why for this release]: re-requesting tracking. This is a more noticeable problem now that the zoom indicator is in the URL by default. I've run into it a few times, and filed bug 1331033 for it, which I'm going to dupe over here.
tracking-firefox53: --- → ?
Botond or Milan, can you help find someone to work on this since kats is out? 
Tracking for 53 since the problem sounds worse in 51 and we see some duplicate bugs being filed.
status-firefox53: --- → affected
tracking-firefox53: ? → +
Flags: needinfo?(botond)
status-firefox51: affected → wontfix
status-firefox52: affected → fix-optional
status-firefox54: --- → affected
tracking-firefox54: --- → +
This is unrelated to APZ, or even to the Layout implementation of browser zoom (since the zoom does get applied to both windows). It seems to be a front-end issue related to the zoom indicator.

Mike, Dão, as the author and reviewer (respectively) of the regressing bugs 869933 and 565718, would one you be able to help with this, or suggest someone who could? Thanks!
Flags: needinfo?(mdeboer)
Flags: needinfo?(dao+bmo)
Flags: needinfo?(botond)

Updated

2 years ago
Depends on: 1345375
Flags: needinfo?(dao+bmo)
Keywords: qawanted → reproducible
Whiteboard: [qawanted, reproduce, bad product reliability]
Flags: needinfo?(mdeboer)

Comment 11

a year ago
I (and I think Dão?) expect this to be fixed after bug 1345375. Jared, is that the case?
Flags: needinfo?(jaws)
Yep, this is fixed.
Status: NEW → RESOLVED
Last Resolved: a year ago
Component: General → Toolbars and Customization
Flags: needinfo?(jaws)
Hardware: x86_64 → All
Resolution: --- → FIXED
Whiteboard: fixed by bug 1345375
Target Milestone: --- → Firefox 55
status-firefox55: --- → fixed
This looks to be fixed in 54. Wontfix for 53, it is getting late in beta to uplift this.
status-firefox53: affected → wontfix
status-firefox54: affected → fixed

Comment 14

a year ago
[bugday-20170308]
status-firefox55: fixed → verified
Flags: qe-verify+
Reproduced this issue using STR from comment 0 and comment 6. (on an old Nightly build)

This is verified fixed on 54 beta 4 (20170501203640) on the following OSes:
- Windows 10 x64
- Mac OS X 10.10.5
- Ubuntu 16.04 x64 LTS
Status: RESOLVED → VERIFIED
status-firefox54: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.