[Calendar]Existing remind me option can be set again when adding new event.

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: swathiks115, Assigned: mmedeiros)

Tracking

unspecified
2.1 S8 (7Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 wontfix, b2g-v2.1 wontfix, b2g-v2.2 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
STR

1.Open calendar app
2.Tap [+] icon.
3. Select an [Remind me] option.
4. Using 'None' in remind me,select same [Remind me] option as same as that in step 3 and repeat to make same options.
(Reporter)

Comment 1

4 years ago
With the above STR, same event is notified many number of times. Example: If "At time of event" is added thrice in Remind me. Three notification occurs for the same event.
Flags: needinfo?(mmedeiros)
(Assignee)

Comment 2

4 years ago
Harly, should we change this behavior?
Flags: needinfo?(mmedeiros) → needinfo?(hhsu)
See Also: → bug 1089802

Comment 3

4 years ago
Hi Miller, this is indeed a strange behavior, and I think we have two ways to deal with this:
1. Do not let the user set same remind time, if user selects "5 minutes before" in the first reminder, the next reminder will not have "5 minutes before" option in the value selector.
2. Let the user set same remind time, and when user save the event, it will only save one reminder and also display only one notification.

Let me know which one you think is more feasible. Thanks
Flags: needinfo?(hhsu) → needinfo?(mmedeiros)
(Reporter)

Comment 4

4 years ago
One more issue is, when we change any Remind me to "None", without selecting OK button it will go back to add event screen. I think only when user selects 'ok' button it should go back to previous(Add event) screen. Is this an issue or expected behavior?
Flags: needinfo?(hhsu)

Comment 5

4 years ago
I have tried on my Flame to add a new event, and change the "5 minutes before" to "None", it will not go back to add event screen unless I tap OK. Therefore, I am not sure what the issue is, could you be more specific?
Flags: needinfo?(hhsu)
(Assignee)

Comment 6

4 years ago
(In reply to Harly Hsu from comment #3)
> 2. Let the user set same remind time, and when user save the event, it will
> only save one reminder and also display only one notification.

way easier to do this way, otherwise we need to rebuild all the select menus every time the user changes the values and we might get into weird edge cases.
Flags: needinfo?(mmedeiros)
(Reporter)

Comment 7

4 years ago
(In reply to Harly Hsu from comment #5)
> I have tried on my Flame to add a new event, and change the "5 minutes
> before" to "None", it will not go back to add event screen unless I tap OK.
> Therefore, I am not sure what the issue is, could you be more specific?

STR 
1. open calendar.
2. select + icon
3. in remind me change "5 minutes before" to "none"

when none is selected it will go back to previous screen(add event)
but if you select any thing other than "none" it will not go to previous screen unless you tap OK button.

Thanks.

Comment 8

4 years ago
(In reply to swathiks115 from comment #7)
> (In reply to Harly Hsu from comment #5)
> > I have tried on my Flame to add a new event, and change the "5 minutes
> > before" to "None", it will not go back to add event screen unless I tap OK.
> > Therefore, I am not sure what the issue is, could you be more specific?
> 
> STR 
> 1. open calendar.
> 2. select + icon
> 3. in remind me change "5 minutes before" to "none"
> 
> when none is selected it will go back to previous screen(add event)
> but if you select any thing other than "none" it will not go to previous
> screen unless you tap OK button.
> 
> Thanks.

I see what you mean. Yes, this is a bug, is there a separate bug addressing this issue?
If not, I am happy to open a new bug for this.
Thanks
Flags: needinfo?(swathiks115)

Comment 9

4 years ago
(In reply to Miller Medeiros [:millermedeiros] from comment #6)
> (In reply to Harly Hsu from comment #3)
> > 2. Let the user set same remind time, and when user save the event, it will
> > only save one reminder and also display only one notification.
> 
> way easier to do this way, otherwise we need to rebuild all the select menus
> every time the user changes the values and we might get into weird edge
> cases.

Yeah, that's what I thought as well. Let's make the modification based on proposal 2 when someone has time to take on this bug.
(Reporter)

Comment 10

4 years ago


(In reply to Harly Hsu from comment #8)
> (In reply to swathiks115 from comment #7)
> > (In reply to Harly Hsu from comment #5)
> > > I have tried on my Flame to add a new event, and change the "5 minutes
> > > before" to "None", it will not go back to add event screen unless I tap OK.
> > > Therefore, I am not sure what the issue is, could you be more specific?
> > 
> > STR 
> > 1. open calendar.
> > 2. select + icon
> > 3. in remind me change "5 minutes before" to "none"
> > 
> > when none is selected it will go back to previous screen(add event)
> > but if you select any thing other than "none" it will not go to previous
> > screen unless you tap OK button.
> > 
> > Thanks.
> 
> I see what you mean. Yes, this is a bug, is there a separate bug addressing
> this issue?
> If not, I am happy to open a new bug for this.
> Thanks

I think there is no bug addressing this issue.

Thanks.
Flags: needinfo?(swathiks115)
(Assignee)

Updated

4 years ago
Assignee: nobody → mmedeiros
Target Milestone: --- → 2.1 S9 (21Nov)
(Assignee)

Comment 11

4 years ago
Created attachment 8518176 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25884
Attachment #8518176 - Flags: review?(gaye)
Comment on attachment 8518176 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25884

This is great. I love the marionette tests you added.
Attachment #8518176 - Flags: review?(gaye) → review+
(Just one nit on GH)
(Assignee)

Comment 14

4 years ago
landed on master: https://github.com/mozilla-b2g/gaia/commit/768d981e2513043a148dd55221069808221cf277
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.0: --- → wontfix
status-b2g-v2.1: --- → wontfix
status-b2g-v2.2: --- → fixed
Resolution: --- → FIXED
Target Milestone: 2.1 S9 (21Nov) → 2.1 S8 (7Nov)
(Assignee)

Updated

4 years ago
Blocks: 1089802
[Environment]
Gaia-Rev        5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a926116946f8
Build-ID        20141111160205
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

[Result]
PASS
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
See Also: → bug 1155098
Per comment 15, set 'status-b2g-v2.2:' as verified.
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.