Closed Bug 1089694 Opened 5 years ago Closed 5 years ago

Profile manager does not remember last used profile

Categories

(Toolkit :: Startup and Profile System, defect)

36 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla36
Tracking Status
firefox35 --- verified
firefox36 + verified

People

(Reporter: alice0775, Assigned: past)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Steps To Reproduce;
1. run 'firefox.exe -P' (without quotation marks)

2. Choose a profile , un-check all checboxes
3. Click [Start Nightly]

4. Exit browser

5. run 'firefox.exe -P' again

Actual Results:
Profile manager does not remember last used profile

Expected results:
Last used profile should be selected
Caused by bug 1024110 maybe?
Flags: needinfo?(past)
Alice, which version/channel are you testing with?
Flags: needinfo?(alice0775)
Regression window(fx)
Good:
https://hg.mozilla.org/integration/fx-team/rev/805c0b62d318
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141024014314
Bad:
https://hg.mozilla.org/integration/fx-team/rev/1416eeab79a2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141024015813
Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=805c0b62d318&tochange=1416eeab79a2
Regressed by:
1416eeab79a2	Panos Astithas — Bug 1024110 - Change Aurora's default profile behavior to use channel-specific profiles. r=bsmedberg f=gavin,markh
Blocks: 1024110
Flags: needinfo?(alice0775)
Keywords: regression
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #2)
> Alice, which version/channel are you testing with?

nightly and default  
(default is tinderbox build)
(In reply to Dave Townsend [:mossop] from comment #1)
> Caused by bug 1024110 maybe?

Yes, I know how to fix this. Taking.
Assignee: nobody → past
Status: NEW → ASSIGNED
Flags: needinfo?(past)
With the introduction of profileService.defaultProfile I missed a spot where the equivalence between selectedProfile and defaultProfile used to be implicit, but now has to be explicit.
Attachment #8512046 - Flags: review?(benjamin)
Attachment #8512046 - Flags: review?(benjamin) → review+
https://hg.mozilla.org/mozilla-central/rev/df5af1c51264
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Comment on attachment 8512046 [details] [diff] [review]
When selecting a profile in the Profile Manager, mark it with Default=1

Approval Request Comment
[Feature/regressing bug #]: bug 1024110
[User impact if declined]: using the profile manager to select a profile and disabling "Use the selected profile w/o asking at startup" will cause the selected profile to be forgotten the next time the user enters the profile manager
[Describe test coverage new/current, TBPL]: m-c, gum
[Risks and why]: trivial patch, virtually zero risk
[String/UUID change made/needed]: none
Attachment #8512046 - Flags: approval-mozilla-aurora?
Whiteboard: [NO_UPLIFT]
Attachment #8512046 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed with latest gum build (buildID: 20141104133445).
No longer an issue with Firefox 35 beta 4 (BuildID=20141216120925) on Windows 7 x64. The latest used profile is correctly remembered.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.