Closed Bug 1089981 Opened 5 years ago Closed 5 years ago

Improve reftests to check both initial frame and steady-state frame rendering

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla38

People

(Reporter: jgilbert, Assigned: jgilbert)

Details

Attachments

(5 files)

Right now, I believe we check frame 2, which gives us no coverage for our initial frame, which is often readback.

Also, some of the reftests are redundant. We don't need to test orientation separately if our color tests can tell us the same thing.
Attachment #8512370 - Flags: review?(dglastonbury)
Attachment #8512372 - Flags: review?(dglastonbury)
Attachment #8513114 - Flags: review?(dglastonbury)
Every single frame=6 test timed out on our infamous Android 2.3 Emu slaves. They couldn't render six frames in one second.

This should also help with GCs from the number of tests we have. I even had a timeout once on one run of my Linux workstation, on a DEBUG build. Only once, and never since, but it's possible.

We could actually increase this to 60s. Really it's just there to keep things moving. It's a little cargo-cult-y, since we never confirmed that rAF would stall. If we get few enough intermittents from this, we can safely remove the timeout failsafe.
Attachment #8513118 - Flags: review?(dglastonbury)
Initial try, where you can see our 16bpp tests failing: (Dithering in action!)
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=fab4a7a901b3

Try is closed right now, or I'd have a new run. I do have to take a look at the DEBUG assert on android 4.0 runs. That looks bad. (OPT works though!)
Attachment #8512369 - Flags: review?(dglastonbury) → review+
Attachment #8512370 - Flags: review?(dglastonbury) → review+
Attachment #8512372 - Flags: review?(dglastonbury) → review+
Attachment #8513114 - Flags: review?(dglastonbury) → review+
Attachment #8513118 - Flags: review?(dglastonbury) → review+
https://hg.mozilla.org/mozilla-central/rev/7f7a164973c3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.