Closed Bug 1090317 Opened 7 years ago Closed 7 years ago

Optimize job eta computation

Categories

(Tree Management :: Treeherder, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Assigned: mdoglio)

References

(Blocks 1 open bug)

Details

(Keywords: perf, regression)

Attachments

(1 file)

In the last meeting it was suggested that we add a small delay to the tooltips shown when hovering the job symbols in the main UI, so that mouse movement didn't trigger hundreds of expensive calculations (eg for ETA) that end up being unused.
Keywords: perf
Assignee: nobody → mdoglio
Keywords: regression
I opened a PR to completely remove the onhover event callback and move the calculation and visualization to the bottom panel
Attachment #8523085 - Flags: review?(emorley)
Status: NEW → ASSIGNED
Summary: Add small delay to job tooltips to prevent mouse movement from triggering unintentionally → Optimize job eta computation
Comment on attachment 8523085 [details] [review]
Github PR #271 on treeherder-ui

r+ but I'd also be interested to see how much of a perf increase we'd get from removing the duration for completed jobs (it's only a time subtraction/formatting, but over a few thousand jobs...?).
Attachment #8523085 - Flags: review?(emorley) → review+
I don't know honestly, I would take care of it in a separate PR. The reason for this one was to avoid running code on hover. If we do it for completed jobs it would be more about jobs load time
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
>+ <span ng-if="eta > 0">{{eta}} mins overdue, tipically takes ~ {{tipical_eta}} mins</span>
>+ <span ng-if="eta == 0">ETA any minute now, typically takes ~ {{tipical_eta}} mins</span>

those should be "typically" and "typical_eta".
Missed review comment:
https://github.com/mozilla/treeherder-ui/pull/271#discussion_r20440712
Flags: needinfo?(mdoglio)
I'm gonna push a fixup directly to master
Flags: needinfo?(mdoglio)
You need to log in before you can comment on or make changes to this bug.