Crash @ java.lang.NullPointerException at org.mozilla.gecko.BrowserApp$14.onStartEditing(BrowserApp.java:735)

RESOLVED DUPLICATE of bug 1138529

Status

()

--
critical
RESOLVED DUPLICATE of bug 1138529
4 years ago
4 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({crash})

34 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox34 affected)

Details

(Reporter)

Description

4 years ago
Found on the Play Store dashboard under Fx34

java.lang.NullPointerException
at org.mozilla.gecko.BrowserApp$14.onStartEditing(BrowserApp.java:735)
at org.mozilla.gecko.toolbar.BrowserToolbar.startEditing(BrowserToolbar.java:1063)
at org.mozilla.gecko.BrowserApp.enterEditingMode(BrowserApp.java:1810)
at org.mozilla.gecko.BrowserApp.enterEditingMode(BrowserApp.java:1788)
at org.mozilla.gecko.BrowserApp.access$400(BrowserApp.java:127)
at org.mozilla.gecko.BrowserApp$9.onActivate(BrowserApp.java:701)
at org.mozilla.gecko.toolbar.BrowserToolbar$3.onClick(BrowserToolbar.java:358)
at android.view.View.performClick(View.java:4569)
at android.view.View$PerformClick.run(View.java:18553)
at android.os.Handler.handleCallback(Handler.java:733)
at android.os.Handler.dispatchMessage(Handler.java:95)
at android.os.Looper.loop(Looper.java:212)
at android.app.ActivityThread.main(ActivityThread.java:5135)
at java.lang.reflect.Method.invokeNative(Native Method)
at java.lang.reflect.Method.invoke(Method.java:515)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:877)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:693)
at dalvik.system.NativeStart.main(Native Method)
The line in question [1], in BrowserApp:

  mDoorHangerPopup.disable();

So mDoorHangerPopup is null.

[1]: https://mxr.mozilla.org/mozilla-beta/source/mobile/android/base/BrowserApp.java?rev=823ecd23138b#735
mDoorHangerPopup is constructed in the super class and nulled only on onDestroy. The call stack is:

onWindowFocusChanged
 initialize
  initializeChrome
   new DoorhangerPopup

Thus, the UI appeared and the toolbar was clicked before onWindowFocusChanged was called. The work in bug 1085591 should fix this issue.

Since I doubt we're going to uplift that and there is no available STR, I'm calling WONTFIX - reopen if you disagree.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Looks like it became a bigger problem in bug 1138529.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1138529
You need to log in before you can comment on or make changes to this bug.