mozilla/xpcom/sample needs updating

RESOLVED FIXED

Status

()

enhancement
P3
normal
RESOLVED FIXED
20 years ago
19 years ago

People

(Reporter: mang, Assigned: dp)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

- check factory example against warren's version
- nsSample CID is defined in nsISample.idl, bad!
- move stuff in README.html to xpconnect-sample.html
Status: NEW → ASSIGNED
QA Contact: desale → mang
- maybe add another implementation class to show that interfaces are not
one-to-one with implementations
- get code review by scc or other
Added mccabe, who may help me make this suck less.

- merged README.html into xpconnect-sample.html
- should wait for nsModule before changing factory code
Oho!

Adding more architect CCs.

Dear architects:  It's critically important that we get at least this one piece
of copiable boilerplate correct.  While doing so, I think we should avoid the
temptation to demonstrate everything.  The sample component should be a good
starting place for people coming to XPCOM.  If we want to demonstrate more
aspects, we should extend the sample in ways that don't distract from a simple
core.

We know that people copy and paste.  Let's get a good canonical place to copy
from.
Actually ccing those lucky folks.
Looks like travis isn't in the list.  Does he have a bugzilla id?
Adding Travis.
Assignee: mang → travis
Status: ASSIGNED → NEW
Re-assigning to Travis, since he seems interested in fighting the good
fight.  (I'm outta here.)
We should be sure to include the stuff in xpcom/build/nsConstructorPattern.cpp
to show how to have good factory hygiene, etc.
Status: NEW → ASSIGNED
Blocks: 15161
Target Milestone: M15
Move to M15.  This is not required for beta 1.
Assignee: travis → dp
Status: ASSIGNED → NEW
This should probably live in DPs group....  Reassigning to him to assign to
someone else.
Assignee: dp → scc
scott, the sample is all yours.
Status: NEW → ASSIGNED
Another quick (I think) thing to fix between the hard problems.
Target Milestone: M15 → M20
mass re-assigning to my new bugzilla account
Assignee: scc → scc
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
I am fixing this. Scott hope you wont mind if I take this one.
Assignee: scc → dp
Status: ASSIGNED → NEW
Uses module code. Ah still doesnt do ProgID in header file.
Status: NEW → ASSIGNED
Attaching a patch that
- moves CID/ProgID into header file
- adds more calls to enablePrivilege
- renames "write" callback to something that works as intended

This makes things go on M15.  (I get "netscape is not defined" with M16; will
track this down.)
patch checked in
r=scc
Ok. So I can close this right. CODE fix.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.