Closed Bug 1090409 Opened 5 years ago Closed 4 years ago

[Home screen/editmode] Scrolling in edit mode causes apps to clip before being fully drawn in

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: rmitchell, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-exploratory-3])

Attachments

(1 file)

82.22 KB, text/plain
Details
Attached file logcat
Description:
Scrolling in edit mode causes apps to clip before being fully drawn in when quickly scrolling up and down 


Repro Steps:
1) Update a Flame to 20141028001203
2) Long press an app to enter edit mode 
3) Scroll from the top to the bottom 
4) Scroll back to the top 


Actual:
App pictures clip before they are fully drawn 


Expected:
app pictures should be fully drawn before screen reaches it and no clipping should occur

Environmental Variables:
Device: Flame 2.1
Build ID: 20141028001203
Gaia: a0174f7166745256aaca1cb3aa9f894033fbffa6
Gecko: 43bda3541f6b
Version: 34.0 (2.1)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency:100%
See attached:logcat video clip:https://www.youtube.com/watch?v=SzLGzCesD6Q
Flags: needinfo?(dharris)
Issue does occur 2.2
apps clip before redrawn 

Flame 2.2

Device: Flame Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141028040202
Gaia: 6a7fb482a03c5083ef79b41e7b0dfab27527cd04
Gecko: a255a234946e
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

issue does not occur in 2.0 
No clip occurs 

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141028000202
Gaia: 5e532a84e762b1bb6231756182cf1465671a061e
Gecko: 124f0bed1700
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
This seems to be a minor issue. Not nominating to block
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.