[Flame] After several calls, dialer menu will be upside down

RESOLVED DUPLICATE of bug 1084252

Status

defect
RESOLVED DUPLICATE of bug 1084252
5 years ago
4 years ago

People

(Reporter: pensacola_m2000, Unassigned)

Tracking

({regression})

unspecified
2.1 S8 (7Nov)
x86
Linux

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Gaia   6a7fb482a03c5083ef79b41e7b0dfab27527cd04
SourceStamp a255a234946e
BuildID 20141028040202
Version 36.0a1
v188 base image
2.2.0 nightly

Steps to reproduce:
1. Make some calls (more than 4) 
2. Check dialer menu

Expected results:
Dialer menu should work as expected, no rendering issues or errors should occur.

Actual results:
After several calls, dialer menu gets upside down. Please see attached screenshot.

The workaround is to close the phone app (long tap on menu button and close phone app card).After that, reopening Phone app, everything works ok.
I have observed this as well. Thanks for reporting it. I will investigate.
Assignee: nobody → drs.bugzilla
Status: NEW → ASSIGNED
Target Milestone: --- → 2.1 S8 (7Nov)
Does not repro on:
Gaia-Rev        eb0aab0f13c78c7ac378ad860e865c4b6eaf669f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/318019f80a8e
Build-ID        20141029001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
blocking-b2g: --- → 2.2?
Keywords: regression
It seems that there was some kind of regression with the 'confirmation-message' element in the Dialer where it's having the 'hide' class unapplied from it for some reason. Thus it's reflowing the entire app window into the wrong place. I suspect that this is a regression with the confirm dialog code, but I need to do more investigation first.
triage: identifiable regression
blocking-b2g: 2.2? → 2.2+
Doug, 

I was able to consistently repro this problem by deleting a contact (from inside the dialer... not inside the contacts app).  After I'd delete the contact, I'd get the upside down.

On a hunch, I applied :cwiiis patch for Bug 1084252 and I can no longer repro the issue this way.  This did have to do with the styling on the confirm dialogs like you mention.

So, with that STR that I used, it fixed it.  I'm not sure what STR was used above.

THanks,

-tamara
Thanks for the investigation, Tamara. Let's make sure that this is fixed once bug 1084252 lands.
Assignee: drs.bugzilla → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1084252

Comment 7

4 years ago
This issue has been verified on Flame 2.2
STR:
1. Make some calls (more than 4) 
2. Check dialer menu
**Dialer menu works as well, no rendering issues or errors occur.
See attachment:2015-01-29-12-10-47.png
Rate:0/5

Flame 2.2 build:
Gaia-Rev        cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d824c65a6a2b
Build-ID        20150128002506
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.035910
FW-Date         Wed Jan 28 03:59:20 EST 2015
Bootloader      L1TC000118D0

Updated

4 years ago

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.