Closed Bug 1090613 Opened 6 years ago Closed 6 years ago

[Browser][Youtube] Switching to 'Settings' app via card view when watching a video in landscape full screen causes undesired behavior

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S8 (7Nov)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: rmead, Assigned: alive)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-exploratory-3] [systemsfe])

Attachments

(2 files)

Attached file Flame2.1logcat.txt
Description:
When watching a video on youtube in fullscreen landscape view, if you go into card view and switch to 'Settings' app, half the settings window will be blank and it will also be unresponsive until you go back into card view.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141028040202
2) Tap the 'Settings' app
3) Tap the Home button
4) Tap the 'Browser' app and go to youtube
5) Switch to landscape view and watch a video in full screen
6) Hold the home button to go into card view
7) Switch to 'Settings' app and observe
  
Actual:
Half the settings window is blank and the whole thing is unresponsive unless you go back into card view.
  
Expected: 
The settings window displays properly.
  

Flame 2.1(319mb)(Kitkat)(Full Flash)

Device: Flame 2.1 
BuildID: 20141028001203
Gaia: a0174f7166745256aaca1cb3aa9f894033fbffa6
Gecko: 43bda3541f6b
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

  
Repro frequency: 100%
See attached: logcat, video - http://youtu.be/qNMgzG65DaI
This issue DOES occur on Flame 2.2(319mb)

When viewing a video on youtube in landscape full screen and then switching to settings app via card view, the settings window will be half blank and unresponsive.

Flame 2.2

Device: Flame Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141028040202
Gaia: 6a7fb482a03c5083ef79b41e7b0dfab27527cd04
Gecko: a255a234946e
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


This issue does NOT occur on Flame 2.0(319mb)

When viewing a video on youtube in landscape full screen and then switching to settings app via cardview, the setting window shows with no issues.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141028000202
Gaia: 5e532a84e762b1bb6231756182cf1465671a061e
Gecko: 124f0bed1700
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

This seems like common user flow and causes the rocket bar to take up half the screen, and renders the settings app unusable.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Contact: aalldredge
----------------------------------------------------
B2G-Inbound Regression Window (Shallow Flash)
----------------------------------------------------

Last Working:
Device: Flame 2.1
BuildID: 20140827210249
Gaia: 39cad6c82122b964f12a66771bfbcc14fb342d9e
Gecko: 52b00288469c
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken:
Device: Flame 2.1
BuildID: 20140827212049
Gaia: 553f7969241ddcd592ac53f25a46230475b87c49
Gecko: 0e901b079a7c
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 39cad6c82122b964f12a66771bfbcc14fb342d9e
Gecko: 0e901b079a7c

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 553f7969241ddcd592ac53f25a46230475b87c49
Gecko: 52b00288469c

Pushlog:
https://github.com/mozilla-b2g/gaia/compare/39cad6c82122b964f12a66771bfbcc14fb342d9e...553f7969241ddcd592ac53f25a46230475b87c49

Caused by Bug 1047143
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by Bug 1047143 - can you take a look Sam?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(sfoster)
QA Contact: aalldredge
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3] [systemsfe]
I'm able to reproduce this. I'll look into it
Assignee: nobody → sfoster
Flags: needinfo?(sfoster)
blocking-b2g: 2.1? → 2.1+
After following the STR, the appchrome div for the Settings app is matching this rule: 

#screen:-moz-full-screen-ancestor .appWindow > div, .appWindow.fullscreen-app > div:not(.titlebar):not(.maximized) {
    top: 0px;
    height: 100%;
}

...ordinarily, when we're not repro'ing this issue this rule does not match, and it seems to be at the heart of the problem. The browser/youtube appwindow was moved to the closed state when the task manager was shown, and by the time I picked the Settings app we were back in portrait anyhow so #screen:-moz-full-screen-ancestor should not be true. 

Beyond this, I don't know this code. Can I hand this off to you Alive?
Flags: needinfo?(alive)
(In reply to Sam Foster [:sfoster] from comment #6)
> After following the STR, the appchrome div for the Settings app is matching
> this rule: 
> 
> #screen:-moz-full-screen-ancestor .appWindow > div,
> .appWindow.fullscreen-app > div:not(.titlebar):not(.maximized) {
>     top: 0px;
>     height: 100%;
> }
> 
> ...ordinarily, when we're not repro'ing this issue this rule does not match,
> and it seems to be at the heart of the problem. The browser/youtube
> appwindow was moved to the closed state when the task manager was shown, and
> by the time I picked the Settings app we were back in portrait anyhow so
> #screen:-moz-full-screen-ancestor should not be true. 
> 
> Beyond this, I don't know this code. Can I hand this off to you Alive?

Good investigation, and by this clue what we need to do is cancel fullscreen mode when opening app from task manager.
Flags: needinfo?(alive)
Target Milestone: --- → 2.1 S8 (7Nov)
Assignee: sfoster → alive
Maybe there is a better place to go but for now let's cancel it here.
Attachment #8517134 - Flags: review?(sfoster)
Comment on attachment 8517134 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/25821

Feeling a little silly, didn't know this would be so simple :)
Attachment #8517134 - Flags: review?(sfoster) → review+
Master
https://github.com/mozilla-b2g/gaia/commit/ff0065856467aef73c7aedf26aab9e27d414ef00
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8517134 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/25821

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Regression from bug 1047143
[User impact] if declined:
User will see white screen if he is having a fullscreen element before invoking task manager and then switch to another app.
[Testing completed]:
Y
[Risk to taking this patch] (and alternatives if risky):
Trivial change, riskless
[String changes made]:
N
Attachment #8517134 - Flags: approval-gaia-v2.1?
Issue still occurs on Flame 2.2 

Actual Result: Half of the screen is covered by blank grey square with youtube play icon in middle when going into settings from Youtube video in landscape via card view.

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141105160209
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: 2114ef80f6ae
Gonk: 
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
Attachment #8517134 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
This issue is verified fixed on Flame 2.1 and 2.2.

Result: The Settings screen is displayed properly.

Device: Flame 2.1 (319mb, KK, Full Flash)
BuildID: 20141110001201
Gaia: 0ec1925fc37b7c71d129ae44e42516a0cfb013c4
Gecko: 97487a2d1ee6
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 (319mb, KK, Full Flash)
BuildID: 20141110040206
Gaia: 5f8206bab97cdd7b547cc2c8953cadb2a80a7e11
Gecko: d380166816dd
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.