Add MPL2.0 to treeherder-[repos] where applicable

VERIFIED FIXED

Status

Tree Management
Treeherder
P2
enhancement
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: jfrench, Assigned: jfrench, Mentored)

Tracking

Details

(Whiteboard: [good first bug][lang=python][lang=js], URL)

Attachments

(6 attachments)

(Assignee)

Description

3 years ago
Just crossed my mind, we might want to inject the MPL2.0 header into relevant file types into applicable treeherder repos.

js:

/* This Source Code Form is subject to the terms of the Mozilla Public
 * License, v. 2.0. If a copy of the MPL was not distributed with this
 * file, you can obtain one at http://mozilla.org/MPL/2.0/. */

py:

# This Source Code Form is subject to the terms of the Mozilla Public
# License, v. 2.0. If a copy of the MPL was not distributed with this
# file, you can obtain one at http://mozilla.org/MPL/2.0/.


And any other file types we might like.

Comment 1

3 years ago
Bah good spot, we really should have been doing this from the start.

Gerv, I'm presuming I need an ack from contributors before adding the header - do I need it from contributors who are employees, or is that a given with their contracts?

The repos are:
https://github.com/mozilla/treeherder-service
https://github.com/mozilla/treeherder-ui
https://github.com/mozilla/treeherder-client (though this one seems to have mostly correct headers already)
Blocks: 1072681
Flags: needinfo?(gerv)
Priority: P5 → P2

Comment 2

3 years ago
Contributor lists:

curl https://api.github.com/repos/mozilla/treeherder-service/contributors | grep 'html_url'
    "html_url": "https://github.com/camd",
    "html_url": "https://github.com/maurodoglio",
    "html_url": "https://github.com/jeads",
    "html_url": "https://github.com/edmorley",
    "html_url": "https://github.com/pnispel",
    "html_url": "https://github.com/uberj",
    "html_url": "https://github.com/KWierso",
    "html_url": "https://github.com/lightsofapollo",
    "html_url": "https://github.com/tojonmz",
    "html_url": "https://github.com/jonasfj",
    "html_url": "https://github.com/Ako0",
    "html_url": "https://github.com/AutomatedTester",
    "html_url": "https://github.com/sylvestre",

curl https://api.github.com/repos/mozilla/treeherder-ui/contributors | grep 'html_url'
    "html_url": "https://github.com/camd",
    "html_url": "https://github.com/jeads",
    "html_url": "https://github.com/maurodoglio",
    "html_url": "https://github.com/tojonmz",
    "html_url": "https://github.com/edmorley",
    "html_url": "https://github.com/wlach",
    "html_url": "https://github.com/pnispel",
    "html_url": "https://github.com/Ako0",
    "html_url": "https://github.com/KWierso",
    "html_url": "https://github.com/AutomatedTester",
    "html_url": "https://github.com/lightsofapollo",
    "html_url": "https://github.com/sylvestre",
    "html_url": "https://github.com/markrcote",
    "html_url": "https://github.com/koddsson",
    "html_url": "https://github.com/mbrubeck",
    "html_url": "https://github.com/laggyluke",
    "html_url": "https://github.com/jeffgodwyll",

curl https://api.github.com/repos/mozilla/treeherder-client/contributors | grep 'html_url'
    "html_url": "https://github.com/jeads",
    "html_url": "https://github.com/maurodoglio",
    "html_url": "https://github.com/camd",

Consolidated:
  https://github.com/Ako0
  https://github.com/AutomatedTester
  https://github.com/KWierso
  https://github.com/camd
  https://github.com/edmorley
  https://github.com/jeads
  https://github.com/jeffgodwyll
  https://github.com/jonasfj
  https://github.com/koddsson
  https://github.com/laggyluke
  https://github.com/lightsofapollo
  https://github.com/markrcote
  https://github.com/maurodoglio
  https://github.com/mbrubeck
  https://github.com/pnispel
  https://github.com/sylvestre
  https://github.com/tojonmz
  https://github.com/uberj
  https://github.com/wlach
If there's been no license thusfar, or if the license has been stated as MPL 2 elsewhere but was not in the headers (as seems to be the case for treeherder-service, at least - it has a top-level LICENSE.txt file), you don't need anyone's permission.

If you told everyone the license was going to be something else, then you need the permission of non-employee contributors.

The LICENSE.txt file in treeherder-service should be called LICENSE, and should contain a copy of:
https://www.mozilla.org/MPL/2.0/index.txt .

Gerv
Flags: needinfo?(gerv)

Comment 4

3 years ago
That's really helpful - thank you :-)

We've either not stated what licence, or have just listed it in the LICENSE.txt file (and not in the headers), so sounds like we're fine and can just make this change.

Updated

3 years ago
Mentor: emorley@mozilla.com
Whiteboard: [good first bug] → [good first bug][lang=python][lang=js]
(Assignee)

Comment 5

3 years ago
Created attachment 8514447 [details]
ui-jsListAll

I had a quick look at the -ui repo recurisvely from /webapp. Since there's very few py, sh, or other file types, I built a js list for Ed to evaluate. I've split the list into three parts - proposed for headers, proposed excluded, and unknown.

Let me know what alterations are required and I'll inject the desired headers.
Attachment #8514447 - Flags: feedback?(emorley)

Comment 6

3 years ago
Comment on attachment 8514447 [details]
ui-jsListAll

Looks good with the following changes:

Unknown:
./test/vendor/  --> exclude
./scripts/web-server.js --> exclude
<everything else in unknown> --> include

Thanks! :-)
Attachment #8514447 - Flags: feedback?(emorley) → feedback+
(Assignee)

Comment 7

3 years ago
Created attachment 8515180 [details] [review]
treeherder-ui-PR#256

Please see the above PR for treeherder-ui. Setting Ed and/or William for review at their leisure, whoever gets to it first.
Attachment #8515180 - Flags: review?(wlachance)
Attachment #8515180 - Flags: review?(emorley)
(Assignee)

Updated

3 years ago
Assignee: nobody → tojonmz
Status: NEW → ASSIGNED
Comment on attachment 8515180 [details] [review]
treeherder-ui-PR#256

Thanks!
Attachment #8515180 - Flags: review?(wlachance)
Attachment #8515180 - Flags: review?(emorley)
Attachment #8515180 - Flags: review+
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

3 years ago
Thanks wlach! Actually we need this bug still open for part2, which is treeherder-service, and then treeherder-client. I figured on using one bug for all. I'll have a look at service next.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

3 years ago
Created attachment 8515343 [details]
service-listProposed

Here's the proposed treeherder-service header candidates, updating .conf .sh .pp and .py files. I've removed the vendor files already. Adding Ed for feedback.

Let me know if anything needs to be pruned.
Attachment #8515343 - Flags: feedback?(emorley)
Comment on attachment 8515343 [details]
service-listProposed

Looks good (excluding ./addPyHeader.sh), thank you :-)
Attachment #8515343 - Flags: feedback?(emorley) → feedback+
(Assignee)

Comment 13

3 years ago
Thanks Ed, will do.
(Assignee)

Comment 14

3 years ago
Created attachment 8516169 [details] [review]
treeherder-service-PR#279

Please see the above PR for treeherder-service.
Attachment #8516169 - Flags: review?(mdoglio)
Attachment #8516169 - Flags: review?(mdoglio) → review+
(Assignee)

Comment 16

3 years ago
Confirmed landed fine on treeherder-service. On to treeherder-client next.
(Assignee)

Comment 17

3 years ago
Created attachment 8524295 [details] [review]
treeherder-client-PR#6

Please see the above PR for treeherder-client.
Attachment #8524295 - Flags: review?(mdoglio)
Attachment #8524295 - Flags: review?(mdoglio) → review+
Comment on attachment 8524295 [details] [review]
treeherder-client-PR#6

https://github.com/mozilla/treeherder-client/commit/a8186c70aed55677136174fd5cda9ffcdd05514f

(The bugzilla & IRC bots were not set up for treeherder-client, have done the latter now, and emailed Wes for the former, since I don't know the bot gmail account password)
(Assignee)

Comment 19

3 years ago
We think we'd like to also add MPL headers to treeherder-node also. Either lightsofapollo or Ed will move the repo to be under /mozilla first, then after that I'll update the files.
I don't have permission to move James' own repo :-)
(Assignee)

Comment 21

3 years ago
Sorry, ya. James has moved his repo now, he indicated in channel it's under automation. I am not sure if that refers to repo ownership, but anyway it is now here https://github.com/mozilla/treeherder-node
(In reply to Jonathan French (:jfrench) from comment #21)
> Sorry, ya. James has moved his repo now, he indicated in channel it's under
> automation. I am not sure if that refers to repo ownership, but anyway it is
> now here https://github.com/mozilla/treeherder-node

Yeah the repo is under the "automation" team on Github. I've also added the "treeherder" team, set up IRC/Bugzilla hooks, adjusted the README/package.json & also places elsewhere that link to the repo (wiki, READMEs in UI/service). Should be good to go now :-)
(Assignee)

Comment 23

3 years ago
Thanks Ed! Headers update coming up shortly.
(Assignee)

Comment 24

3 years ago
Created attachment 8524742 [details] [review]
treeherder-node-PR#3

Please see above PR for review and status.
Attachment #8524742 - Flags: review?(mdoglio)

Updated

3 years ago
Attachment #8524742 - Flags: review?(mdoglio) → review+
(Assignee)

Comment 26

3 years ago
I think we are done here, so unless anyone has anything else I'm marking this fixed, and also marking verified based on the current states of the repo.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.