Closed Bug 1090783 Opened 7 years ago Closed 7 years ago

Gaia build fails on some linuxes with "build/utils.js: Invalid file path ()" due to $DESKTOP

Categories

(Firefox OS Graveyard :: Gaia::Build, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aphitiel, Assigned: rickychien)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141026030205

Steps to reproduce:

* Pull fresh gaia
* run 'make'


Actual results:

Build fails like this:
Test SDK directory: /home/ap/git/gaia/b2g_sdk/34.0a1-2014-08-12-04-02-01
<snip>
run-js-command gaia/app
Exception: Error:  -*- build/utils.js: Invalid file path ()
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsILocalFile.initWithPath]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> file:///home/ap/git/gaia/build/utils-xpc.js :: getFile :: line 149"  data: no]

getFile@resource://gre/modules/commonjs/toolkit/loader.js -> file:///home/ap/git/gaia/build/utils-xpc.js:164:11
exports.execute@resource://gre/modules/commonjs/toolkit/loader.js -> file:///home/ap/git/gaia/build/app.js:39:18
CommonjsRunner.prototype.run@/home/ap/git/gaia/build/xpcshell-commonjs.js:109:5
run@/home/ap/git/gaia/build/xpcshell-commonjs.js:124:3
@-e:1:1

make: *** [app] Error 1


Expected results:

Clean build
Cause: Env-var DESKTOP is put into BUILD_CONFIG in Makefile. On this system DESKTOP=Enlightenment-0.17.0.

BUILD_CONFIG is parsed as JSON in build/xpcshell-commonjs.js, which silently fails due to parse error.

Adding quotes around $(DESKTOP) in Makefile:488 fixes the problem.
Summary: Gaia build fails with "build/utils.js: Invalid file path ()" → Gaia build fails on some linuxes with "build/utils.js: Invalid file path ()" due to $DESKTOP
Upon further consideration, I think DESKTOP should be initialized to 0 if not set to 1.

'DESKTOP=0 make' works without the above hack.
Attached file Gaia PR
Attachment #8526652 - Flags: review?(gduan)
Attachment #8526652 - Flags: review?(gduan)
Attached file Gaia PR
Thank you for reporting this bug. Patch is submitted!

I ensure all $(VAR) to "$(VAR)" in BUILD_CONFIG.
Assignee: nobody → ricky060709
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8526660 - Flags: review?(gduan)
Comment on attachment 8526660 [details] [review]
Gaia PR

r=gduan
Attachment #8526660 - Flags: review?(gduan) → review+
Merged.

https://github.com/mozilla-b2g/gaia/commit/f5d050542cc0c3fb46da2ede6d7f1edc30fa57c6
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
See Also: → 1233293
You need to log in before you can comment on or make changes to this bug.