Change Gaia keyboard app listen to surroudingtexchange event

RESOLVED DUPLICATE of bug 1228778

Status

Firefox OS
Gaia::Keyboard
RESOLVED DUPLICATE of bug 1228778
4 years ago
3 years ago

People

(Reporter: rudyl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

+++ This bug was initially created as a clone of Bug #906614 +++

Since bug 899999 has landed, we need to change the implementation of latin IME engine in Gaia keyboard app to use onsurroundingtextchange to react any changes made to the input field by content app.

See bug 1085764 comment 23 for a use case which would need this.
Blocks: 899999, 1085764
Should be a dup to bug 1228778 since we would now call IMEngine#stateChange on surroundingtextchange event.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1228778
You need to log in before you can comment on or make changes to this bug.