[FLAME] Neither ACCEPT, REJECT, or DIAL buttons do anything

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
--
blocker
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Matěj Cepl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8513431 [details]
output of adb logcat

When I dial a phone number on the numerical pad, when I try to accept a call, or even reject it, phone doesn't react to my pressing button (slowly or swiftly, many times or once, it doesn't matter). That make phone kind of useless.

The attached is the output of adb logcat when dialing from the number dialpad.

Using Nightly as of 2014-10-29 on v188 base image (build ID 20141028040202)
(Reporter)

Comment 1

3 years ago
Created attachment 8513433 [details]
output of adb logcat

Hopefully this better log. 

W/Communications( 2307): [JavaScript Error: "TypeError: navigator.mozPhoneNumberService is undefined" {file: "app://communications.gaiamobile.org/shared/js/fb/fb_data_reader.js" line: 236}]

Gives me hope for the speedy analysis and resolution.
blocking-b2g: --- → 2.2?
Flags: needinfo?(drs.bugzilla)

Updated

3 years ago
Duplicate of this bug: 1090915
(In reply to Matěj Cepl from comment #0)
> Using Nightly as of 2014-10-29 on v188 base image (build ID 20141028040202)

Did you do a shallow flash of nightly on top of v188 or did you do a full image flash? I can't reproduce this issue on my flame using v188 + a full-image flash. That being said I don't have facebook synchronization enabled on my phone, do you?
(Reporter)

Comment 4

3 years ago
(In reply to Gabriele Svelto [:gsvelto] from comment #3)
> Did you do a shallow flash of nightly on top of v188 or did you do a full
> image flash? I can't reproduce this issue on my flame using v188 + a
> full-image flash. That being said I don't have facebook synchronization
> enabled on my phone, do you?

a) the latter (shallow flash on top of v188)
b) no, I don't like Facebook

When updating to the very latest Nightly (which was not available here when I wrote the bug report) the situation seems to be better. I haven't got any call yet, but I was able to dial.

Comment 5

3 years ago
I can confirm the bug also using shallow flash on top of v188

I had facebook sync disabled. Now enabled but without difference.

I tried to debug the dialer app in webide and app-manager but can't see any of the installed apps in them.

Comment 6

3 years ago
We have to differenciate whats "able to call".

I can confirm that I'm able to call when sim1 is the default for outgoing calls.

Like I said in Bug 1090915 I'm not able to select the sim. Neither through long press to change from the default sim or through setting "always ask"+single tap. the dialog doesn't appear to select the sim.

so maybe there was a fix between the last two nightlies but the problem still exists for the selection between sim1 and sim2
QAWanted to do branch check on 2.1 and 2.2
Keywords: qawanted
I can confirm the last sentence in comment 6. I'm able to dial just fine but the user cannot change the Sim 1 and Sim 2 in Flame 2.2 KK latest. This is a separate bug. Was it filed already?

Tested with Shallow Flash on 319mb using Engineering builds

This bug does NOT repro on Flame kk build: Flame 2.2 KK, Flame 2.1 KK

Actual Result: Able to make and accept calls and dial numbers on the keypad.

Repro Rate: 0/4

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141031062029
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 21fbf1e35090
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141031025654
Gaia: 224dfde17af943b583aa0a97936343c7267c7996
Gecko: 12a56ce89cb9
Version: 34.0 (2.1) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Suggest we close this as WFM once we verify the other issue (sim 1 and sim 2) was written up
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(mcepl)
QA Contact: croesch

Comment 10

3 years ago
should i reopen my other bug because its not really a duplicate anymore?
(Reporter)

Comment 11

3 years ago
(In reply to Joshua Mitchell [:Joshua_M] from comment #9)
> Suggest we close this as WFM once we verify the other issue (sim 1 and sim
> 2) was written up

Probably no problem ... I don't see it on the current Nightly anymore. Will reopen once it happens again (if that happens again).
Flags: needinfo?(mcepl)
Per comment 11
Status: NEW → RESOLVED
blocking-b2g: 2.2? → ---
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 13

3 years ago
okay, I will reopen bug 1090915 because the sim1/sim2 dialog is still missing. and it seems to be a different case.
Flags: needinfo?(drs.bugzilla)
You need to log in before you can comment on or make changes to this bug.