Adblock Plus 2.6.5.3871 doesn't block ads with Nightly (2014-10-29)

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
4 years ago
8 months ago

People

(Reporter: Virtual, Assigned: gaubugzilla)

Tracking

(Blocks: 1 bug, {addon-compat, nightly-community, regression})

Firefox 36
x86_64
Windows 7
addon-compat, nightly-community, regression
Dependency tree / graph

Firefox Tracking Flags

(firefox35 unaffected, firefox36 verified)

Details

(Whiteboard: [Fixed in Adblock Plus 2.6.5.3872 (dev) and 2.6.6 (stable)])

Few errors like these are shown in Error Console:

Timestamp: 2014-10-29 15:18:02
Error: f.readTo is not a function
Source File: resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///C:/Users/Virtual_ManPL/AppData/Roaming/Mozilla/Firefox/Profiles/93fe7q9t.default/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/bootstrap.js -> jar:file:///C:/Users/Virtual_ManPL/AppData/Roaming/Mozilla/Firefox/Profiles/93fe7q9t.default/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/lib/io.js
Line: 179



and one message:

Could not read chrome manifest 'file:///C:/Program%20Files%20(x86)/Nightly/browser/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/chrome.manifest'.
Keywords: regression, regressionwindow-wanted
status-firefox35: --- → unaffected
status-firefox36: --- → affected
Summary: Adblock Plus 2.6.5.3871 is broken with Nightly (2014-10-29) → Adblock Plus 2.6.5.3871 doesn't block with Nightly (2014-10-29)
Summary: Adblock Plus 2.6.5.3871 doesn't block with Nightly (2014-10-29) → Adblock Plus 2.6.5.3871 doesn't block ads with Nightly (2014-10-29)

Comment 2

4 years ago
I'm also having an error today. What I'm experiencing is not that Adblock plus doesn't block ads, but that the filters are deleted on every browser restart.
(Assignee)

Comment 3

4 years ago
David, I guess Adblock Plus should use read() instead of readTo()? The idea here was offloading the garbage collector a bit by using only one array buffer.
Flags: needinfo?(dteller)
If you could migrate ABP to use `read()`, that would be great.
Indeed, `readTo()` was introduced specifically for the reason you mention, but it turns out that this prevents the JS team from improving the garbage-collector.
It shouldn't be too hard to write a variant of `readTo()` that would work, but it cannot keep the same API either way.
Flags: needinfo?(dteller)
Wladimir, do you want to migrate to `read()` or would you prefer a replacement `readTo()` first?

Something along the lines of:

/**
 * Optimized variant of `read` that doesn't need to allocate a buffer.
 *
 * @param {TypedArray} buffer The buffer that will contain the data.
 * This buffer is neutered by the call, and cannot be reused.
 * @param {*} options
 *
 * @return {TypedArray} The buffer, with the data.
 */
readTo(buffer, options)
Flags: needinfo?(trev.moz)
(Assignee)

Comment 7

4 years ago
No need for an intermediate solution, my change is already up for review: http://codereview.adblockplus.org/6083164824928256. I think it's too late for a release next week, we should release on November 11 if everything is ok.
Flags: needinfo?(trev.moz)
(Assignee)

Comment 8

4 years ago
Adblock Plus 2.6.6 is out (reviewed by AMO a few minutes ago), the issue is fixed there.

Given that this is in the Tech Evangelism component, I'm resolving as FIXED.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Thank you very much!
Status: RESOLVED → VERIFIED
status-firefox36: affected → verified
Whiteboard: [Fixed in Adblock Plus 2.6.5.3872 (dev) and 2.6.6 (stable)]
See Also: → bug 1103561
You need to log in before you can comment on or make changes to this bug.