[flatfish][Ar][TCP][keyboard] missing letters

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Keyboard
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Benlamara, Assigned: rudyl)

Tracking

({regression})

unspecified
2.2 S1 (5dec)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8513542 [details]
2014-10-29-15-55-14.png

User Agent: Mozilla/5.0 (Tablet; rv:36.0) Gecko/36.0 Firefox/36.0
Build ID: 20141024014828

Steps to reproduce:


Use the arabic keyboard 
press the ي letter to show the alternative letters (ى )


Actual results:

The letters are hidden or missing (even if when selected it works just fine )
(Reporter)

Updated

3 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Will look at this as soon as I can, please ping me on this account in the future :)
Thanks for reporting! :)
It can not be reproduced in Flatfish build of 20141010. So I hope it is a regression. I am looking taking this to test in the build of 20141029.
QA Contact: safwan.rahman15
Is this issue still occurring or is it safe to close this bug?
(In reply to Andrew Truong [:feer56] from comment #3)
> Is this issue still occurring or is it safe to close this bug?

Will be doing a check on this later today.
I am confirming the bug with the reference of Bug 1096226.
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → bug 1096226
Should be a regression caused by bug 1085359.
The label in the alternative char menu would be hidden by the following rule,
https://github.com/mozilla-b2g/gaia/commit/72f1fb27761a6400e8b5c11b85099b2cd4f2d509#diff-f44fe3e079720e197e7dcd3c35f8b661L126
Blocks: 1085359
Duplicate of this bug: 1096226
See Also: bug 1096226
Since bug 1085359 only landed to master, so mark only 2.2 as affected.
Assignee: nobody → rlu
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Keywords: regression
Created attachment 8528994 [details] [review]
Patch V1

This is a one-line CSS patch so that we won't hide the key label in the alternative char menu as the keys in the menu are generated each time, so it won't be necessary to control its show/hide with .lowercase CSS class.

Tim, could you help review this change?
Thank you.
Attachment #8528994 - Flags: review?(timdream)
Status: NEW → ASSIGNED
Comment on attachment 8528994 [details] [review]
Patch V1

Thanks for fixing the regression, however the this simply overwrites properties with a stronger specificity, so it's really not easy to tell why that rule is needed.

A better thing to do is to split the KeyView for alternative menus and layout pages, and have them adopt their own set of styles; something I have suggested but I haven't heard you back.

Anyway, we should rearrange the stylesheet after the views are split.
Attachment #8528994 - Flags: review?(timdream) → review+
I tend to fix the regression first (with comments added), and file another bug for a better fix.
Thanks.

--
master,
https://github.com/mozilla-b2g/gaia/commit/13787076664949e55ac9c6ad283fa8ecb6472e08
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S1 (5dec)
You need to log in before you can comment on or make changes to this bug.