Some ringtones don't block background audio correctly.

RESOLVED FIXED

Status

Firefox OS
AudioChannel
P3
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: squib, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master unaffected)

Details

(Reporter)

Description

4 years ago
This seems to happen most of the time, but not *all* the time:

1) Play some music from the music app
2) Go to Settings -> Sound -> Manage Tones
3) Preview the "Classic" ringtone
4) Wait for the ringtone to end: music starts playing again immediately

Step (4) doesn't happen for most of the other ringtones: they correctly stop playback of the background music *until the ringtone app is hidden*.

I checked, and the AudioContext we're using to block background music is still present after step (4), so I don't know what the issue is. Maybe something specific to that file?

Comment 1

4 years ago
Confirmed on v2.1.

------

Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141118161207
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
OS: Windows 7 → Gonk (Firefox OS)
Priority: -- → P3
Hardware: x86_64 → ARM

Comment 2

3 years ago
Behavior has been corrected by new audio channel.
Blocks: 1089539
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: --- → unaffected
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.