Youtube videos using MSE sometimes stop painting the video in full screen mode

RESOLVED FIXED

Status

()

P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I've now hit this twice, both with youtube videos that use MSE (according to the DASH section of "stats for nerds".)  I reproduced the bug roughly by doing the following:

Open <http://icelandairwaves.is/schedule/#!programmation=artist$shura-uk/66>, click on the name of the youtube video to open it in a new tab, and immediately hit the full screen button when the playback starts.

The video stops to pain fairly early (about maybe 5 seconds into the video as if that is the last frame, and the audio keeps playing back.  I had to reload the page in order to get the video to paint again.

But of course this doesn't reproduce reliably.
(Reporter)

Updated

4 years ago
Blocks: 778617
I've had this issue on Linux but I put that down to Ubuntu having a week-old build. It could be related to the skip to next keyframe logic.
This should be re-tested once bug 1091992 merges to nightly. Also if we get a different fix in bug 1112445 that may help too.
Flags: needinfo?(mozillamarcia.knous)
Tested with the latest nightly on both Mac 10.10.2 and Windows 8.1 Pro:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20150102030211 CSet: 13fe5ad0364d

I don't seem to be getting a consistent painting issue with this video, but certainly something else is making the experience worse on Mac with this video in full screen. I can spinoff another bug if it helps.

Using FF Dev Edition I see stuttering and several times in full screen it consistently froze 9 seconds into the video. Using Mac Nightly I saw the stuttering a few times as well. On Windows 8.1 the video seemed to play fine.
Flags: needinfo?(mozillamarcia.knous)

Updated

4 years ago
Priority: -- → P2
Depends on: 1121280
Blocks: 1121280
No longer depends on: 1121280
I've seen this on recently Windows and on Linux in the past. I don't believe it is platform specific.
Priority: P2 → P1
It seems pretty likely that fullscreen would change which resolution stream we're getting, and then this could be explained by the various other hanging bugs which have been fixed (mostly fuzzy offset stuff).

Ehsan, have you seen this recently? (In the past week).
There are a number of fixes in yesterday's nightly that should fix your issue. Can we close this?
Flags: needinfo?(ehsan)
(Reporter)

Comment 7

4 years ago
Yes, this seems to be fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ehsan)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.