Closed Bug 1091342 Opened 7 years ago Closed 7 years ago

Enable updates via ship-it

Categories

(Release Engineering :: Applications: Shipit (backend), defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1119417

People

(Reporter: lmandel, Unassigned)

References

Details

As a thought, it would be nice to be able to enable updates via ship-it. This will allow more self service for relman. Ideas (and these are admittedly not well thought out):
1. Feedback on current update rate and # instances updated (as a percentage of average ADI)
2. a slider to control 0-100% updates
3. a way to schedule throttling changes based on time (ex, 24 hours) or % uptake (ex, 25%)
1 and 2 will be relatively easy once we're on Balrog. We may want bug 1062187, too.

Not sure about 3...we don't have an existing system to schedule things like that.

This is also one part of the more general bug 886522 - which talks about all post release tasks.
Blocks: 886522
Depends on: balrog-release, 1062187
Mass component change for ship it bugs.
Component: Release Automation → Ship It
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119417
You need to log in before you can comment on or make changes to this bug.