Closed Bug 1091407 Opened 5 years ago Closed 5 years ago

Poor playback on YouTube 60fps video

Categories

(Core :: Audio/Video, defect, P1)

x86
macOS
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Dolske, Unassigned)

References

(Blocks 1 open bug)

Details

I just came across a YouTube clip that looked different, and I realized it's 60fps. A bit of Googling indicated that YouTube just announced it today -- http://www.theverge.com/2014/10/29/7121143/youtube-adds-support-for-60fps-video-playback (oddly, the video I'm linking to is a year a half old).

Unfortunately the playback in Firefox is terrible. It will occasionally play for a bit at what looks like 60fps, but not smoothly, and it frequently just stops entirely (0fps) for multiple seconds. Audio seems fine, however.

I'm on a current Nightly, OS X 10.10, no Flash installed.
The clip: https://www.youtube.com/watch?v=dNFaAqS2f18

WARNING: this is video of a motorcycle crashing into 2 bicyclists. It's not gory enough to have been removed from YouTube, but some will find it disturbing. Description says the guy was ok after an overnight hospital stay -- no death or pools of blood.

The whole video seems to be janky, so you can skip to 1:40+ to avoid the worst of it and still see playback problems.
(I get the same results in a new profile. Plays silky-smooth without problems in Chrome.)
Glob said it was working for him, so on a lark I tried rebooting. And now it's working fine for me. O_o

That makes me vaguely suspect something like video drivers/hw getting into a funky state, since I could previously reproduce it in a separate profile. (Chrome worked, but maybe it tickles things differently.)

I also just WFM'd bug 1087095 as now being unreproducible. Wonder if it's the same underlying issue?

If there's some extra debugging info I can grab when the problem is happening, that might help narrow down what's actually going wrong. (In 1087095 I ran a debug build to reproduce, with no obvious errors reported in the console.)
Is it possible that you just upgraded Flash recently before you saw this? We've had several reports of seeing jank if Firefox is running while Flash is automatically updated, although I've only seen that on Windows previously.
No, it's not possible. I don't even have Flash installed on this system. :)
Have you seen this again? Seems to work fine for me.
Is this still an issue?
Flags: needinfo?(dolske)
I haven't seen the glitches I remember originally seeing for this bug, so lets call this WFM. I do still have general playback issues, but that seems to be covered by bug 1100000.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(dolske)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.