Closed Bug 1091466 Opened 5 years ago Closed 5 years ago

MediaCodecReader should defer releaseOutputBuffer() to another thread while using GraphicBuffer.

Categories

(Core :: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1091467

People

(Reporter: brsun, Assigned: bechen)

References

Details

This is a follow-up bug of bug 1033903.

MediaCodecReader should defer MediaCodecProxy::releaseOutputBuffer() onto another thread instead of call it on the same thread that calls AtomicRefCountedWithFinalize(a base class of TextureClient)::mRecycleCallback.
Bug 1033903 comment 10 says defer the |releaseOutputBuffer()| to another thread will deadlock, that is because the patch use |mLooper| thread. Since all responses are posted to the mLooper thread, we can not post any tasks to mLooper.
And the bug 1099303 comment 15 is not exactly correct, it should be "always" deadlock, not "sometimes".

Now, I'm trying to defer the |releaseOutputBuffer()| to videoTaskQueue.
Assignee: nobody → bechen
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1091467
You need to log in before you can comment on or make changes to this bug.