[Settings] Developer menu is not appearing anymore

RESOLVED DUPLICATE of bug 1092941

Status

--
major
RESOLVED DUPLICATE of bug 1092941
4 years ago
4 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR:
1. enable developer menu in Settings > Device Information > More Information
2. come back to first panel and scroll to bottom

=> no "developer menu"
=> same if I kill/restart the settings app

This is really blocking me with my development, I don't have adb anymore on my buri (and on buri I can't flash eng builds because they're too big).

Arthur, I'd appreciate if you can have a look asap, so that tomorrow's nightly would at least have this fixed...
Flags: needinfo?(arthur.chen)
Severity: normal → blocker
Seems to happen on Buri, but not on Flame.
I was not able to reproduce it neither on a Flame nor a Buri. Does the settings db work correctly? Are you able to toggle other settings?
Flags: needinfo?(arthur.chen) → needinfo?(felash)
Ok, so, today, it works fine (same build than when I reported the bug).

It takes some time to appear (I see the "Operator Services" title at the bottom during some time), so maybe there still is something strange.

I'm closing this bug for now, but maybe you'd like to investigate why it's slow to appear.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(felash)
Resolution: --- → WORKSFORME
Ok, actually, it seems to appear sometimes. When this appears I can't flip anything:
* Airplane mode is disabled
* enabling usb storage doesn't work
* I see "operator services" title at the end

So, reopening. But this is weird.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
All of these sound like settings db problem and something similar happened before (bug 1061510) although I'm not sure whether they are the same thing. Which build are you using?
I'm using a nightly from master/central from last thursday. Now that I recovered adb :) I can try to update with a newer build.
So, I got it once with a build from today, but I can't make it appear on the same build now. I have enabled adb and the console so I'll keep trying and I'll make sure to have a log if I see it again.
Severity: blocker → major
Janx could reproduce it, and here is what we have in the log when this happened:

11-03 09:47:39.222  1822  1822 W Settings: [JavaScript Error: "TypeError: depMap is undefined" {file: "app://settings.gaiamobile.org/js/vendor/alameda.js" line: 1195}]

Hope this helps!
And afterwards, when I kill the Settings app, I get:

W/GeckoConsole( 1644): [JavaScript Error: "TypeError: this.element is null" {file: "app://system.gaiamobile.org/js/app_window.js" line: 232}]
I/Gecko   ( 2200): 
I/Gecko   ( 2200): ###!!! [Child][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
I/Gecko   ( 2200): 

And when I open it again, I get the following (but not the aforementioned alameda.js error):

I/Settings( 2200): Content JS LOG: BluetoothHelper(): connot get default adapter!!! 
I/Settings( 2200):     at BluetoothHelper/_fetchAdapter/req.onerror (app://settings.gaiamobile.org/shared/js/bluetooth_helper.js:104:8)
I/Gecko   ( 2229): ###################################### forms.js loaded
I/Gecko   ( 2229): ############################### browserElementPanning.js loaded
I/Gecko   ( 2229): ######################## BrowserElementChildPreload.js loaded
W/Settings( 2200): Content JS WARN: No callbacks for method getAccounts 
W/Settings( 2200):     at onMessage (app://settings.gaiamobile.org/shared/js/fxa_iac_client.js:89:10)
OS: Linux → All
Hardware: x86_64 → All
I also observed [JavaScript Error: "TypeError: depMap is undefined" {file: "app://settings.gaiamobile.org/js/vendor/alameda.js" line: 1195}], but there is no specific STR.

The bluetooth error is because it tries to get the adapter when the bluetooth hardware is not ready. It is not related to the issue here.
The specific STR: launch the application, and sometimes there is this issue ;)

Difficult to debug, I know... 

But I flash my Buri every 2/3 days, and I got this issue only starting 10/30. So maybe we can try to backout some patches that landed before this and see if this happens...

Comment 12

4 years ago
Was able to reproduces the issue on 2.2 Flame every day, about 30% repro.
Developer menu doesn't show up, requires to restart the device

Device: Flame 2.2 Master KK
BuildID: 20141105160209
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: 2114ef80f6ae
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
The day 10/30 reminds me the regression caused by bug 1082001. When it occurs, any access to moz settings is going to fail. The regression has just been solve in bug 1092941. I can see if that fixes the issue.
It could definitely be this. I hope ! :)
It doesn't seem to happen again, let's close this then.
Thanks Arthur!
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1092941
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.