crash in java.lang.IllegalStateException: at android.media.MediaCodec.flush(Native Method)

VERIFIED FIXED

Status

()

Firefox for Android
General
--
critical
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: snorp)

Tracking

({crash, reproducible, topcrash-android-armv7})

36 Branch
All
Android
crash, reproducible, topcrash-android-armv7
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox34+ unaffected, firefox35+ verified, firefox36+ verified, fennec34+)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-200ccc65-74c6-4a79-ad69-b297e2141029.
=============================================================

java.lang.IllegalStateException
	at android.media.MediaCodec.flush(Native Method)
	at dalvik.system.NativeStart.run(Native Method)
	at dalvik.system.NativeStart.run(Native Method)
tracking-fennec: ? → 35+
[Tracking Requested - why for this release]: 
Currently the #1 topcrash in Fennec 35.0a2 accounting for 11.66% of all crashes.
status-firefox35: --- → affected
tracking-firefox35: --- → ?
tracking-firefox36: --- → ?
Keywords: topcrash-android-armv7
No longer blocks: 1014614
Depends on: 1014614, 1086693
Planning to fix this with bug 1086693
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #2)
> Planning to fix this with bug 1086693

What's the priority to fix that bug? I'm extremely concerned about this crash as it's caused a huge spike in overall Aurora stability[1][2]. We have a relatively low user base on Aurora as it stands, but I want to make sure this is on track to be fixed before Fennec 35 hits Beta.

1. https://crash-stats.mozilla.com/daily?p=FennecAndroid&v=35.0a2
2. https://crash-analysis.mozilla.com/rkaiser/2014-11-09/2014-11-09.fennecandroid.aurora.explosiveness.html
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #3)
> (In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #2)
> > Planning to fix this with bug 1086693
> 
> What's the priority to fix that bug? I'm extremely concerned about this
> crash as it's caused a huge spike in overall Aurora stability[1][2]. We have
> a relatively low user base on Aurora as it stands, but I want to make sure
> this is on track to be fixed before Fennec 35 hits Beta.
> 
> 1. https://crash-stats.mozilla.com/daily?p=FennecAndroid&v=35.0a2
> 2.
> https://crash-analysis.mozilla.com/rkaiser/2014-11-09/2014-11-09.
> fennecandroid.aurora.explosiveness.html

Landing bug 1086693 is my top priority. My plan is to uplift it to both 34 and 35.
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #4)
> Landing bug 1086693 is my top priority. My plan is to uplift it to both 34 and 35.

Great, thanks! I'll stop distracting you. :)
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #4)
> Landing bug 1086693 is my top priority. My plan is to uplift it to both 34
> and 35.

I don't see anything in this bug about the crash impacting 34. Is there a need to uplift to 34?
Flags: needinfo?(snorp)
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #6)
> (In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #4)
> > Landing bug 1086693 is my top priority. My plan is to uplift it to both 34
> > and 35.
> 
> I don't see anything in this bug about the crash impacting 34. Is there a
> need to uplift to 34?

I think maybe we've only hit it in 35, but it's the exact same code in 34. We'll want to uplift the fix there.
tracking-fennec: 35+ → 34+
status-firefox34: --- → affected
Flags: needinfo?(snorp)
This is 100% reproducible on Firefox 34 Beta 8 and latest Aurora:
Steps:
1. Go to http://cd.pn/b2/
2. Tap on video to bring up the video controls 
3. Tap anywhere on the progress bar

Result: Firefox will crash with the above signature
Keywords: reproducible

Comment 9

3 years ago
Given how large that exploded in Aurora, I think we should not ship a beta that has this bug.
tracking-firefox34: --- → +
tracking-firefox35: ? → +
tracking-firefox36: ? → +
After reviewing the required fix in bug 1086693 and discussing with snorp and kar, we decided to disable the new media backend (bug 1097276) and ship to Android L users without media playback in 34.
status-firefox34: affected → unaffected
I'm seeing this crash on a current Aurora build on KitKat. Is that expected?
https://crash-stats.mozilla.com/report/index/e1110457-f8b0-4dd4-affa-3c1a12141116
(Reporter)

Comment 12

3 years ago
What's the status here?
We haven't uplifted to Aurora yet. I'm going to try to do that today.
Nevermind, RyanVM uplifted it today already. He's the best. So this bug should be fixed in Nightly already and in the next Aurora.

Comment 15

3 years ago
Numbers on Aurora seem to come down after the uplift of bug 1086693, so I'm calling this FIXED for now. If we continue to see those crashes, we should REOPEN, though.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox35: affected → fixed
status-firefox36: affected → fixed
Resolution: --- → FIXED
Flags: qe-verify+
Catalin, can you please verify this is fixed?
Flags: needinfo?(catalin.suciu)
I'm not able to reproduce this crash using the steps from comment #8 on latest Aurora and Nightly
Status: RESOLVED → VERIFIED
status-firefox35: fixed → verified
status-firefox36: fixed → verified
Flags: needinfo?(catalin.suciu)
You need to log in before you can comment on or make changes to this bug.