Closed Bug 1091783 Opened 7 years ago Closed 7 years ago

Fix gaia-integration tests that depend on searchTimeout for findElements being broken in marionette server

Categories

(Firefox OS Graveyard :: Gaia::TestAgent, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ahal, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

I recently discovered that the searchTimeout functionality of findElements in marionette server doesn't work. Bug 1084412 fixes the error, but unfortunately there are a few places in the integration-tests that only worked *because* of this error, so the patch in bug 1084412 got backed out.

Here are the failures with that patch applied:
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=ca9443b50d7a&searchQuery=js-integration

We need to fix these up and somehow coordinate the landings here with the fix in bug 1084412.
Attached patch Fix clock tests (obsolete) — Splinter Review
I did a bit of debugging, and the clock tests are broken because the waitFor times out before the call to findElements [1] times out. This worked previously because findElements used to ignore the "searchTimeout" parameter and returned immediately.

This patch fixes the tests for me locally.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/clock/test/marionette/lib/actions.js#L68
This should fix up most of the errors caused by the patch in bug 1084412. I couldn't reproduce the failures in chunk 4 though (see https://treeherder.mozilla.org/ui/logviewer.html#?job_id=2802251&repo=try) and stack doesn't seem to have findElements anywhere on it, is that a known issue?
Attachment #8514446 - Attachment is obsolete: true
Try run that should have both server and test changes:
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=7aa6b9a4d8ce
Ugh, I spelt "githib" in that last push, here's a new one:
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=39212b51fc49
This run has a fix for the previous failure in chunk 3, but there seems to be an intermittent in chunk 4:
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=71a0f0c28536

Is this a known intermittent? :kgrandon said he'd never seen it before..

Looks likely that it's unrelated because I didn't see any invocations of findElements near the traceback path. I'll go ahead with review + landing unless someone objects.
Comment on attachment 8514521 [details] [review]
Fix up most of the tests

Not sure who the best person to ask review of this is, could you re-direct if appropriate? Thanks!
Attachment #8514521 - Flags: review?(jlal)
Comment on attachment 8514521 [details] [review]
Fix up most of the tests

+ mcav for clock change, + kgrandon for system app changes.
Attachment #8514521 - Flags: review?(m)
Attachment #8514521 - Flags: review?(kgrandon)
Attachment #8514521 - Flags: review?(jlal)
Comment on attachment 8514521 [details] [review]
Fix up most of the tests

Hmm, seems like poorly written waits? I'm fine landing this if it helps you get unblocked though. Thanks.
Attachment #8514521 - Flags: review?(kgrandon) → review+
Attachment #8514521 - Flags: review?(m) → review+
(In reply to Kevin Grandon :kgrandon from comment #8)
> Comment on attachment 8514521 [details] [review]
> Fix up most of the tests
> 
> Hmm, seems like poorly written waits? I'm fine landing this if it helps you
> get unblocked though. Thanks.

I'm not in any particular rush to land bug 1084412. If you or someone else would rather take this over and fix it properly, that's fine by me. I'll go ahead and land this tomorrow if I don't hear otherwise.
https://github.com/mozilla-b2g/gaia/commit/4e02f34e4994e98af6a752daf452f7c218f242ff
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.