[Dialer] ConfirmDialog broken after deleting call logs.

RESOLVED DUPLICATE of bug 1084252

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1084252
3 years ago
3 years ago

People

(Reporter: GaryChen, Unassigned)

Tracking

({regression})

unspecified
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

Attachments

(1 attachment)

Created attachment 8514764 [details]
2014-10-31-08-37-51.png

STR
 Step1. launch Dialer
 Step2. switch to 'call logs' panel.
 Step3. tap ":V" icon on the top right
 Step4: select one or all call logs.
 Step5: tap "Delete" icon on the top right
 Step6: KO

[Expected Result]
ConfirmDialog hide and selected logs will be deleted.
[Error]
ConfirmDialog was broken and Dialer can not be used.
please refer to attachment.
status-b2g-v2.0: --- → unaffected
status-b2g-v2.0M: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Keywords: regressionwindow-wanted
[Blocking Requested - why for this release]: Noticeable regression
blocking-b2g: --- → 2.2?
Keywords: regression
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20141015113215
Gaia: 841d0d7d1b879f0ff4b5a8727f5dd23c7b0000a9
Gecko: a280a03c9f3c
Platform Version: 36.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141016065647
Gaia: 5c636a7a54b2c86d8ff6bc1aa1e5f9594c7bc586
Gecko: 9fe9bace9ed5
Platform Version: 36.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 841d0d7d1b879f0ff4b5a8727f5dd23c7b0000a9
Gecko: 9fe9bace9ed5
Broken Gaia / Working Gecko = Repro
Gaia: 5c636a7a54b2c86d8ff6bc1aa1e5f9594c7bc586
Gecko: a280a03c9f3c
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/841d0d7d1b879f0ff4b5a8727f5dd23c7b0000a9...5c636a7a54b2c86d8ff6bc1aa1e5f9594c7bc586


B2G Inbound
Last working
BuildID: 20141015070318
Gaia: a18559e844b6aec946309a3bee6a32ca06ab4649
Gecko: fe4916e0e9df
Platform Version: 36.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141015102818
Gaia: 93fb5070782a549977cf8c485c5d93de54ec657e
Gecko: 069db53e0f68
Platform Version: 36.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: a18559e844b6aec946309a3bee6a32ca06ab4649
Gecko: 069db53e0f68
Broken Gaia / Working Gecko = Repro
Gaia: 93fb5070782a549977cf8c485c5d93de54ec657e
Gecko: fe4916e0e9df
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/a18559e844b6aec946309a3bee6a32ca06ab4649...93fb5070782a549977cf8c485c5d93de54ec657e
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Most likely broken by bug  Bug 1078295 - can you take a look Chris?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(chrislord.net)
QA Contact: ckreinbring
triage: regression,
blocking-b2g: 2.2? → 2.2+

Comment 5

3 years ago
The patch on bug 1084252 fixes this and adds a test for it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(chrislord.net)
Resolution: --- → DUPLICATE
Duplicate of bug: 1084252
You need to log in before you can comment on or make changes to this bug.