Updating from Firefox 32 to 33.0.2 on a laptop with switchable graphics results in a black page

RESOLVED DUPLICATE of bug 1083071

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1083071
4 years ago
4 years ago

People

(Reporter: fijam7, Unassigned)

Tracking

33 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8514885 [details]
screenshot1.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141027150301

Steps to reproduce:

Background: I have a Samsung series 7 laptop with switchable graphics (Intel GPU and AMD HD 8570M) running Windows 8.1 x64. I updated Firefox 32 to 33.0.2 and it no longer works on AC power instead displaying a solid black window.


Actual results:

Following update from Firefox 32 to Firefox 33, I get a completely black window with just the window borders visible (screenshot1.png) if I launch the browser when the laptop is plugged into AC power (this presumably uses AMD HD8570M). When I launch the browser with the laptop on battery power (using Intel GPU) it works fine (see support.txt). I cannot force Firefox to use Intel GPU on AC power (the power profile is locked in Samsung settings app) and as a result, I can only use Firefox on battery power. 


Expected results:

Update does not break the application.
(Reporter)

Comment 1

4 years ago
Created attachment 8514886 [details]
support.txt
(Reporter)

Updated

4 years ago
OS: Windows 7 → Windows 8.1

Comment 2

4 years ago
See the "Whiteboard" of bug 1083071.
The best solution is to update your Intel drivers.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083071
You need to log in before you can comment on or make changes to this bug.