[Notifications screen] downloads in progress can disappear and reappear when tapping 'clear all'

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
4 years ago
2 months ago

People

(Reporter: Petes, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3] 2.6UXnom, URL)

(Reporter)

Description

4 years ago
Description:
When user has downloads in progress and pulls down the Notifications screen, the downloads bar can disappear and reappear when tapping 'clear all'

Setup Steps:
1) Flame device is set to 319mb

Repro Steps:
1) Update a Flame device to BuildID: 20141031001201
2) Download any file from  https://owd.tid.es/dm/
3) Pull down the Notifications screen
4) Repeatedly tap 'clear all'


Actual:
downloads in progress can disappear and reappear 

Expected:
Downloads clear when download is completed

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031001201
Gaia: f89c7b12c36572262c9ea76058694a139b1a8634
Gecko: 50d48f8a04c7
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
See attached: video, logcat, https://www.youtube.com/watch?v=INAy7MIec0w
(Reporter)

Comment 1

4 years ago
This issue also reproduces on the Flame 2.2 and the Flame 2.0, the downloads in progress can disappear and reappear.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031061804
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 6bd2071b373f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031000201
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
NI to component / Notification Menu owner  - Gerry - can you tell us if this is intended design or a bug?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gchang)
I think this is intended design, but still need UX's confirmation.
Hi Amy, 
Can you help to determine if this is intended design.
Flags: needinfo?(gchang) → needinfo?(amlee)

Comment 4

4 years ago
(In reply to Gerry Chang [:cfchang] from comment #3)
> I think this is intended design, but still need UX's confirmation.
> Hi Amy, 
> Can you help to determine if this is intended design.

Hi Gerry, 

I'm not involved with UX for notifications so NI'ing Rob for UX feedback.
Flags: needinfo?(amlee) → needinfo?(rmacdonald)
adding Francis who worked on download manager.
Flags: needinfo?(fdjabri)
(In reply to Gerry Chang [:cfchang] from comment #3)
> I think this is intended design, but still need UX's confirmation.
> Hi Amy, 
> Can you help to determine if this is intended design.


This isn't the intended design - if the user clears the notifications, they should clear, but if so the user should receive a notification when the file has finished downloading or fails.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(fdjabri)
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3] 2.6UXnom

Comment 7

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.