Closed Bug 1092566 Opened 5 years ago Closed 4 years ago

[META] IOS-61 - Home Panels - Bookmarks

Categories

(Firefox for iOS :: General, defect, P1)

All
iOS 7
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: mfinkle, Unassigned)

References

Details

One of the fucntional pages in the iOS app will be centered on Bookmarks.

Some ideas discussed so far:
* Pull the bookmarks from the attached Firefox Account/Sync service
* Allow opening bookmarks in other browsers
* Allow opening bookmarks in the built-in Reader
* Display bookmarks in a frecency order, but allow people to look at them all
* Use a search feature to find subsets of bookmarks, making it easier to navigate large bookmark trees

Questions:
* Do we allow management?
* Do we show folders? Is "search" enough?
We also talked about showing only 'Recently bookmarked' instead of letting people browse the classic hierarchical structure. Maybe that, combined with Search is enough?
Folder navigation seems out of scope for v1.0 IMO. I was merely bringing it up for a future consideration.
Flags: needinfo?(krudnitski)
A v1 could be to flatten out all of the folders and just have one list as your back-up (for the one time you REALLY need *that* bookmark), with the core use case being served by search & recently bookmarked.

Could that make sense? Do-able?

Actual management should be on the roadmap for the future since I think we'll need to support that use-case going forward when FxA grabs hold as the central source of browser data 'truth'. We're just not there yet though.
Flags: needinfo?(krudnitski)
Depends on: 1096965
We have a bookmarks page. I don't really think its useful to have these sub-meta bugs around (i.e. the bookmarks page will likely always have bugs, so we can never close this). Anyone opposed to just closing this (and the other bugs like it?)
Dunno, I kind of like the grouping under the meta bugs because I use the tree view in bugzilla a lot to get an idea of outstanding work per 'component'.
Group: mozilla-employee-confidential
OS: Linux → iOS 7
Product: Firefox for Android → Firefox for iOS
Hardware: x86_64 → All
Version: Trunk → unspecified
Summary: (ios) [meta] Bookmarks page → [META] IOS-61 - Home Panels - Bookmarks
Duplicate of this bug: 1130490
Blocks: iosv1
Depends on: 1127040
No longer blocks: ios
Priority: -- → P1
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.