Closed Bug 1093079 Opened 6 years ago Closed 2 years ago

Intermittent test_bluetooth.html | application crashed [@ mozilla::ClearOnShutdown<mozilla::StaticRefPtr<mozilla::dom::bluetooth::BluetoothServiceChildProcess> >]

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: crash, intermittent-failure, Whiteboard: [test disabled on B2G debug][leave open])

b2g_emulator_vm mozilla-inbound debug test mochitest-debug-12

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=3527791&repo=mozilla-inbound

06:28:43 WARNING - PROCESS-CRASH | /tests/dom/permission/tests/test_bluetooth.html | application crashed [@ mozilla::ClearOnShutdown<mozilla::StaticRefPtr<mozilla::dom::bluetooth::BluetoothServiceChildProcess> >]
06:28:43 INFO - Crash dump filename: /tmp/tmpfNsnZZ/0fd1a058-d6c2-5be9-299d2e48-1779ba0a.dmp
06:28:43 INFO - Operating system: Android
06:28:43 INFO - 0.0.0 Linux 2.6.29-g41a03df #22 Thu Jun 26 10:59:09 CST 2014 armv7l Android/full/generic:4.0.4.0.4.0.4/OPENMASTER/eng.cltbld.20141103.063227:eng/test-keys
06:28:43 INFO - CPU: arm
06:28:43 INFO - 0 CPUs
06:28:43 INFO - Crash reason: SIGSEGV
06:28:43 INFO - Crash address: 0x0
06:28:43 INFO - Thread 0 (crashed)
06:28:43 INFO - 0 libxul.so!mozilla::ClearOnShutdown<mozilla::StaticRefPtr<mozilla::dom::bluetooth::BluetoothServiceChildProcess> > [ClearOnShutdown.h : 82 + 0x4]
06:28:43 INFO - r4 = 0x00000001 r5 = 0x00000000 r6 = 0x402769a0 r7 = 0x402769a0
06:28:43 INFO - r8 = 0xbec4cb84 r9 = 0x00000000 r10 = 0x00000005 fp = 0x42913207
06:28:43 INFO - sp = 0xbec4ca38 lr = 0x41b218a5 pc = 0x41b218a8
06:28:43 INFO - Found by: given as instruction pointer in context
06:28:43 INFO - 1 libxul.so!mozilla::dom::bluetooth::BluetoothChild::BluetoothChild [BluetoothChild.cpp:8ea35244fcfd : 43 + 0x3]
06:28:43 INFO - r4 = 0x40275940 r5 = 0x00000000 r6 = 0x402769a0 r7 = 0x402769a0
06:28:43 INFO - r8 = 0xbec4cb84 r9 = 0x00000000 r10 = 0x00000005 fp = 0x42913207
06:28:43 INFO - sp = 0xbec4ca58 pc = 0x41b21aa7
06:28:43 INFO - Found by: call frame info
06:28:43 INFO - 2 libxul.so!mozilla::dom::bluetooth::BluetoothServiceChildProcess::Create() [BluetoothServiceChildProcess.cpp:8ea35244fcfd : 55 + 0x3]
06:28:43 INFO - r4 = 0x40254c18 r5 = 0x432c46a8 r6 = 0x40275940 r7 = 0x402769a0
06:28:43 INFO - r8 = 0xbec4cb84 r9 = 0x00000000 r10 = 0x00000005 fp = 0x42913207
06:28:43 INFO - sp = 0xbec4ca70 pc = 0x41b24739
06:28:43 INFO - Found by: call frame info
06:28:43 INFO - 3 libxul.so!mozilla::dom::bluetooth::BluetoothService::Create() [BluetoothService.cpp:8ea35244fcfd : 245 + 0x3]
06:28:43 INFO - r4 = 0x00000000 r5 = 0x00000000 r6 = 0x432c46a0 r7 = 0x417704c1
06:28:43 INFO - r8 = 0xbec4cb84 r9 = 0x00000000 r10 = 0x00000005 fp = 0x42913207
06:28:43 INFO - sp = 0xbec4ca90 pc = 0x41b1f309
06:28:43 INFO - Found by: call frame info
06:28:43 INFO - 4 libxul.so!mozilla::dom::bluetooth::BluetoothService::Get() [BluetoothService.cpp:8ea35244fcfd : 691 + 0x3]
06:28:43 INFO - r4 = 0x00000000 r5 = 0x00000000 r6 = 0x432c46a0 r7 = 0x417704c1
06:28:43 INFO - r8 = 0xbec4cb84 r9 = 0x00000000 r10 = 0x00000005 fp = 0x42913207
06:28:43 INFO - sp = 0xbec4ca98 pc = 0x41b1f81b
06:28:43 INFO - Found by: call frame info
Based on bug 891840 comment 407, this appears to be an issue of test_bluetooth.html moving from the beginning on chunk 13 to the end of chunk 12. This already caused one innocent patch to be backed out and appears to be spiking again, so I'm disabling the test until the latent timebomb is fixed.

https://hg.mozilla.org/integration/mozilla-inbound/rev/ad25e056d812
Component: DOM: Content Processes → Bluetooth
Product: Core → Firefox OS
Whiteboard: [test disabled on B2G debug][leave open]
Version: Trunk → unspecified
Duplicate of this bug: 1097021
Closing all intermittent test failures for Firefox OS (since we're not focusing on it anymore).

Please reopen if my search included your bug by mistake.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.