Closed Bug 1093200 Opened 5 years ago Closed 5 years ago

Crash on a page with PDF.js + canvas iterating over pages

Categories

(Firefox for Android :: General, defect)

33 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1091677

People

(Reporter: davidventura27, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.1.0
Build ID: 20140903072827

Steps to reproduce:

Iterating over a heavy PDF (5MB+) and doing some canvas rendering (+ posting the resulting image) crashes firefox every time.

Example:
http://jsfiddle.net/zkq19spu/2/


I can provide the PDF if needed



Actual results:

Firefox Crashed (silently)


Expected results:

Firefox shouldn't close itself. at least not without an error
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1091677
You need to log in before you can comment on or make changes to this bug.