(App-grouping) Increase hit target for collapse button in group.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Hung Nguyen, Assigned: cwiiis)

Tracking

unspecified
2.2 S5 (6feb)
x86
Mac OS X

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe], [ux-most-wanted])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8516186 [details]
collapse_hittarget.png

Looking to increase the hit target of the collapse button in a group with affecting the visuals. 

I've attached the page from the spec but it can also be found here: 

https://bugzilla.mozilla.org/show_bug.cgi?id=1086514
(Reporter)

Updated

4 years ago
Blocks: 1086514
Whiteboard: [systemsfe]
(Reporter)

Updated

4 years ago
Assignee: nobody → chrislord.net
(Assignee)

Updated

4 years ago
Blocks: 1067435
No longer blocks: 1086514
(Assignee)

Comment 1

4 years ago
The hit-target for the element in question is already 3rem, unfortunately: https://github.com/mozilla-b2g/gaia/blob/master/shared/elements/gaia_grid/style.css#L216

I remember finding that a 2rem height hit-target made it basically impossible to hit altogether.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 2

4 years ago
Created attachment 8547674 [details]
AppGrouping_IncreaseHitTargets_Spec.png

new spec from Hung, to increase touch target of expand/collapse button
Attachment #8516186 - Attachment is obsolete: true

Comment 3

4 years ago
reopening with updating spec to increase touch target to 4 rem. (see Hung's latest spec attached).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 4

4 years ago
Ni'ing Chris just to check in on the status of this...
Flags: needinfo?(chrislord.net)

Updated

4 years ago
Whiteboard: [systemsfe] → [systemsfe], [ux-most-wanted]
Created attachment 8559247 [details] [review]
[PullReq] Cwiiis:bug1093270-increase-group-header-hit-target to mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
Comment on attachment 8559247 [details] [review]
[PullReq] Cwiiis:bug1093270-increase-group-header-hit-target to mozilla-b2g:master

Just CSS changes, seems to work.
Flags: needinfo?(chrislord.net)
Attachment #8559247 - Flags: review?(kgrandon)
Comment on attachment 8559247 [details] [review]
[PullReq] Cwiiis:bug1093270-increase-group-header-hit-target to mozilla-b2g:master

Looks good to me, thanks!
Attachment #8559247 - Flags: review?(kgrandon) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
blocking-b2g: --- → 2.2?
(Assignee)

Comment 9

3 years ago
Come on, this is clearly not a bug that should block release :p As it's a small change, I'm sure uplift will be no problem. Let's let it sit for a couple of days to make sure there's nothing obvious wrong.
blocking-b2g: 2.2? → ---
Target Milestone: --- → 2.2 S5 (6feb)
(Assignee)

Comment 10

3 years ago
Comment on attachment 8559247 [details] [review]
[PullReq] Cwiiis:bug1093270-increase-group-header-hit-target to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Can be hard to hit expand/collapse arrow
[Testing completed]: Tested manually and been on master for a week
[Risk to taking this patch] (and alternatives if risky): Low risk of performance degradation due to z-index changes (but I've not noticed any)
[String changes made]: None
Attachment #8559247 - Flags: approval-gaia-v2.2?
(In reply to Chris Lord [:cwiiis] from comment #10)
> Comment on attachment 8559247 [details] [review]
> [PullReq] Cwiiis:bug1093270-increase-group-header-hit-target to
> mozilla-b2g:master
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #):
> [User impact] if declined: Can be hard to hit expand/collapse arrow
> [Testing completed]: Tested manually and been on master for a week
> [Risk to taking this patch] (and alternatives if risky): Low risk of
> performance degradation due to z-index changes (but I've not noticed any)
PLease do keep an eye on any perf regressions that may fallout here. Thanks!
> [String changes made]: None

Updated

3 years ago
Attachment #8559247 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/d205e24d6dae5f227baf57f9956cb1fc90d91e06
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
This issue is verified fixed on Flame 3.0

The hit boxes for the collapse and expand group icons on the homescreen have been increased in size to properly reflect what is seen in the UX spec sheet.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150211010216
Gaia: 8c7865486a1b11076b849bbf8f7fccbaffbfafe7
Gecko: ee093ca70666
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
-------------------------------------------------------------------------------------------------------------
adding verify me keyword for this issue to be verified on 2.2
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 14

3 years ago
Created attachment 8563190 [details]
verified picture: verify.jpg

This issue has been verified successfully on latest Flame2.2

Verify picture:"verify.jpg".
**You can see the "collapse button" size on Flame 2.2 is the same as that in “collapse_hittarget.png” of Comment 0.

Flame 2.2 build:
Build ID               20150211002505
Gaia Revision          943be6fd146017dcd9d4c9d1027be1e43bad13eb
Gaia Date              2015-02-11 08:01:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e614443583e7
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150211.040242
Firmware Date          Wed Feb 11 04:02:53 EST 2015
Bootloader             L1TC000118D0

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.