[Browser] Requires an internet connection error is overlapped by check settings in landscape mode

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rmitchell, Assigned: gmarty)

Tracking

({polish})

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 verified, b2g-v2.1S fixed, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-exploratory-3][systemsfe])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8516358 [details]
logcat_20141103_1636.txt

Description:
The X Requires an internet connection error is overlapped by check settings in landscape mode 

Repro Steps:
1) Update a Flame to 20141103001220
2) turn off data and wifi or turn on air plane mode 
3) search something on the browser/ rocket bar 

Actual:
Check settings overlaps part of error message in landscape 


Expected:
Check settings does not overlap part of error message in landscape

Environmental Variables:
Device: Flame 2.1
Build ID: 20141103001220
Gaia: 027a7de0c95320cea0579bfd1a4ceef3e9038f34
Gecko: ffecb2be228b
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency:100%

See attached:screenshot Logcat
Flags: needinfo?(jmitchell)
(Reporter)

Comment 1

4 years ago
This issue DOES  occur on flame 2.2 (319mb)(Kitkat Base)(Full Flash) 

Overlap occurs

Flame 2.2


Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141103040202
Gaia: bc168c17474dabbcceaa349e9bc7c95654435aec
Gecko: 5999e92e89ff
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-------------------------------------------------------------------------------------------------
Issue does NOT occur on  2.0 (319mb)(Kitkat Base)(Full Flash)
Page in question did not exist 
 
Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141103000201
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
(Reporter)

Comment 2

4 years ago
Created attachment 8516360 [details]
logcat_20141103_1636.txt
(Reporter)

Comment 3

4 years ago
Created attachment 8516368 [details]
2014-11-03-19-26-35.png
NI to browser owner for blocking call
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(mozillamarcia.knous)
Not ideal, but we do have a number of issues where layout seems to be an issue in landscape mode. As long as the message displays, I wouldn't consider it a blocker. Adding the polish keyword.
Flags: needinfo?(mozillamarcia.knous)
Keywords: polish
I revisited this one after talking to bajaj and am nominating it for 2.2. I suspect there may be more of these type of windows where the layout is not ideal in landscape.
blocking-b2g: --- → 2.2?
Can we get some UX help here?
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3][systemsfe]

Comment 8

4 years ago
Flagging Francis.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(fdjabri)
blocking-b2g: 2.2? → 2.2+
Hi Eric - Can you take a look at this one? - Rob
Flags: needinfo?(epang)
Could we float-left the icon in landscape mode?
(Assignee)

Updated

4 years ago
Assignee: nobody → gmarty
Created attachment 8537786 [details]
updated landscape spec.png

I agree with Chris, moving the icon to the left makes sense in landscape.  I've attached a spec, Guillaume let me know if this will work. Thanks!
Flags: needinfo?(gmarty)
Flags: needinfo?(fdjabri)
Flags: needinfo?(epang)
(Assignee)

Comment 12

4 years ago
Created attachment 8537827 [details] [review]
Github PR

Here is a patch. Eric, can you please ui-review it? Thanks!
Flags: needinfo?(gmarty)
Attachment #8537827 - Flags: ui-review?(epang)
Comment on attachment 8537827 [details] [review]
Github PR

Hey Guillaume, this looks much better to me! R+

Just wanted to mention that we talked about how vertically centering the text would be too difficult to do.
Attachment #8537827 - Flags: ui-review?(epang) → ui-review+
(Assignee)

Comment 14

4 years ago
Comment on attachment 8537827 [details] [review]
Github PR

Ben, can you please have a look at this set of changes?
Attachment #8537827 - Flags: review?(bfrancis)
Comment on attachment 8537827 [details] [review]
Github PR

Looks good to me! Forwarding review to a module owner.
Attachment #8537827 - Flags: review?(timdream)
Attachment #8537827 - Flags: review?(bfrancis)
Attachment #8537827 - Flags: feedback+
Target Milestone: --- → 2.2 S3 (9jan)
Comment on attachment 8537827 [details] [review]
Github PR

Stealing this review since I have done all the net_error reviews.

Solution seems fine to me. Had one small nitty question on github, but I won't block the review on it. Thanks!
Attachment #8537827 - Flags: review?(timdream) → review+
(Assignee)

Comment 17

4 years ago
Landed in https://github.com/mozilla-b2g/gaia/commit/04b8c6f033bb838883da0f1abfb9e55ca699f47a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Is this something that should land on v2.1 as well? If so, please request Gaia v2.1 approval on it :)
status-b2g-v2.2: affected → fixed
Flags: needinfo?(gmarty)
Guillaume, can you request an uplift?
(Assignee)

Comment 20

4 years ago
Comment on attachment 8537827 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Browser app
[User impact] if declined: Bad UX when there is no connectivity and the phone is on landscape orientation
[Testing completed]: Manual testing required
[Risk to taking this patch] (and alternatives if risky): Very low as it only impacts the appearance
[String changes made]: none
Flags: needinfo?(gmarty)
Attachment #8537827 - Flags: approval-gaia-v2.1?(bbajaj)
Comment on attachment 8537827 [details] [review]
Github PR

This would ideally not block the release but given the super low risk css change here and also that was bug was not present in 2.0, I am approving uplift. 

If we have any fallouts due to this, we should immediately back this out..
Attachment #8537827 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+

Comment 23

4 years ago
This issue dose not exist on Flame 2.2:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150114002502
Version         37.0a2
Reproduce rate  0/5
status-b2g-v2.2: fixed → verified

Comment 24

4 years ago
This issue dose not exist on Flame 2.1:
Gaia-Rev        8d4846d7bec777046dc5e3d2b8005adb1370f1f7
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8eb9bc3a945a
Build-ID        20150115001207
Version         34.0
Reproduce rate  0/5
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.