white space appearing between images in unpadded table

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: bulbul, Assigned: attinasi)

Tracking

({testcase})

Trunk
mozilla1.1alpha
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:20011128], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Horizontal white space is appearing between images in a table currently on the
front page of <http://www.RedHat.com>. I imagine that the content of that page
will change soon. I've quoted the relevant code below. I'll post a screenshot of
what i'm seeing. The page is rendered correctly in Konqueror.

I see this in Linux trunk builds 2001-10-12-08 and 2001-11-07-15.

---------------------------

<div align="center">
<table border="0" cellspacing="0" cellpadding="0">
<tr>
<td><a href="blah">
<img src="/img/hp_train_promo1.gif" alt="Red Hat Linux 7.2" width="180"
height="101" border="0"></a>
</td>
<td><a href="blah">
<img src="/img/hp_train_promo2.gif" alt="Learn 7.2 like the back of your hand"
width="310" height="101" border="0"></a>
</td>
</tr>

<tr>
<td><a href="blah"><img src="/img/hp_train_promo3.gif" alt="Red Hat Linux 7.2"
width="180" height="46" border="0"></a>
</td>
<td><a href="blah">
<img src="/img/hp_train_promo4.gif" alt="The industry's leading training courses
are now updated for Red Hat Linux 7.2" width="265" height="46" border="0"></a>
</td>
</tr>

<tr>
<td><a href="blah">
<img src="/img/hp_train_promo4a.gif" alt="Red Hat Linux 7.2" width="180"
height="27" border="0"></a><br /><a href="blah">
<img src="/img/hp_train_promo5.gif" alt="Red Hat Linux 7.2" width="180"
height="55" border="0"></a>
</td>
<td valign="top"><a href="blah">
<img src="/img/hp_train_promo6.gif" alt="Enroll now and save $200" width="165"
height="27" border="0"></a><br /><a href="blah">
<img src="/img/hp_train_promo7.gif" alt="BUY Red Hat Linux 7.2" width="140"
height="27" border="0"></a></td>
</tr>
</table>
</div>
(Reporter)

Comment 1

17 years ago
Created attachment 57237 [details]
image of incorrect rendering

Comment 2

17 years ago
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">

bug 22274?

Comment 3

17 years ago
Confirming issue in the Nov 9th build under Mac OS X and Windows 2000.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
saw the gap some days ago - but with a CVS pulled including checkins up through
11/14/2001 02:06 shows no white gaps. (RH7.1)

Comment 5

17 years ago
WFM, 2001-11-25-08 on Windows 98 SE.
http://www.redhat.com now uses the following DOCTYPE:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

Comment 6

17 years ago
the spacing between the images is still present on all platforms, I know Marc 
has seen this problem with whitespace between cells/rows
Keywords: testcase
OS: Linux → All
Priority: -- → P3
Hardware: PC → All
Whiteboard: [bae:20011128]
Target Milestone: --- → mozilla1.1
(Reporter)

Comment 7

17 years ago
Comment 5 implies that a change in behavior has occurred in displaying the
RedHat site because RedHat has changed its doctype, but comment 3 (which was
made the same day this bug was created) suggests that this "new" doctype is the
same doctype which was being used when the bug was first reported.
(Reporter)

Comment 8

17 years ago
Sorry to spam, but i meant comment 2 and comment 5.

Comment 9

17 years ago
WFM, 2002-01-25-03 (trunk) on Windows 98 SE.

Leston, the two DOCTYPEs are different, this one triggers standard mode layout:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">

and this one triggers quirk mode layout:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

http://www.redhat.com now uses the last one.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.