Closed Bug 1093626 Opened 8 years ago Closed 8 years ago

type in text field doesn't show on techpinions.com

Categories

(Web Compatibility :: Desktop, defect)

Firefox 33
x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rjensen, Unassigned)

References

()

Details

(Whiteboard: [css][contactready])

Attachments

(1 file)

On some web pages when I type in text fields it doesn't who the text. It registeres it but doesn't show. I.e
http://techpinions.com
This is a bug in the website. It sets box-sizing: border-box, defines a small height, and then defines padding that exceeds the border box, meaning the content height is 0. It should adjust its CSS.
Component: General → Desktop
Product: Firefox → Tech Evangelism
See Also: → 1084906
Version: 33 Branch → Trunk
Version: Trunk → Firefox 33
To reproduce: 
1) Load http://techpinions.com/
2) Place cursor in search field 
3) Type - no text appears

Suggested fix:
1) Remove 

padding: 17px 10px !important;

from the .searchbar CSS block.

2) Check that there's no similar styling applied to other input fields.
Summary: type in text field doesn't show → type in text field doesn't show on techpinions.com
Whiteboard: [css][contactready]
If you use Chrome the site applies the same styling - why don't Chrome users see the same problem?
Flags: needinfo?(dholbert)
Flags: needinfo?(dbaron)
(In reply to Hallvord R. M. Steen from comment #3)
> If you use Chrome the site applies the same styling - why don't Chrome users
> see the same problem?

See bug 1084906 comment 2 and bug 1084906 comment 7, and from there on http://lists.w3.org/Archives/Public/www-style/2014Nov/0037.html (which sadly seems to have no replies so far)
Flags: needinfo?(dholbert)
Flags: needinfo?(dbaron)
The good thing about that bug is that the thread is still going on with pretty interesting discussions on implementation differences in between IE, Chrome and Firefox.
Looks like its working on latest nightly!
Great! It looks like the site fixed its CSS -- the "padding: 17px 10px !important" declaration that was mentioned in comment 2 has now been changed to "padding: 5px 10px !important".

So, there's much less vertical padding, which leaves some space for the content-box per comment 1.

So, I think we can call this FIXED as a Tech Evang bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
See Also: → 1117532
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.