Closed Bug 1093721 Opened 8 years ago Closed 8 years ago

When starting reftests: "JavaScript strict warning: resource://gre/modules/Webapps.jsm, line 575: ReferenceError: reference to undefined property Components.classes['@mozilla.org/app-migrator;1']"

Categories

(Core Graveyard :: DOM: Apps, defect)

defect
Not set
normal

Tracking

(firefox38 fixed)

RESOLVED FIXED
mozilla38
Tracking Status
firefox38 --- fixed

People

(Reporter: dholbert, Assigned: cpeterson)

References

()

Details

Attachments

(1 file)

STR:
 1. Start a local reftest run, with "./mach reftest". Inspect your terminal output.

ACTUAL RESULTS:
Early on in the output (line 25 for me), this goes by:
{
JavaScript strict warning: resource://gre/modules/Webapps.jsm, line 575: ReferenceError: reference to undefined property Components.classes['@mozilla.org/app-migrator;1']
}

EXPECTED RESULTS: No such warning spam.


Looks like this is from this code (really line 704 of Webapps.jsm):
> 702         // Run migration before uninstall of core apps happens.
> 703         try {
> 704           let appMigrator = Components.classes["@mozilla.org/app-migrator;1"].createInstance(Components.interfaces.nsIObserver);
> 705           appMigrator.observe(null, "webapps-before-update-merge", null);

http://mxr.mozilla.org/mozilla-central/source/dom/apps/Webapps.jsm?rev=87f031a85885&mark=704-704#702

qDot added this line in bug 1058180; marking as blocking that bug.
Flags: needinfo?(kyle)
Thanks for the heads up, will get this fixed.
Assignee: nobody → kyle
Flags: needinfo?(kyle)
Duplicate of this bug: 1074988
I see this annoying ReferenceError every time I run a Firefox debug build.

Avoid ReferenceError when trying to instantiate Components.classes['@mozilla.org/app-migrator;1']

qJavaScript strict warning: resource://gre/modules/Webapps.jsm, line 626: ReferenceError: reference to undefined property Components.classes['@mozilla.org/app-migrator;1']

Also remove some user of SpiderMonkey's nonstandard language extensions:

* change legacy generators to ES6 generators.
* change for-each-in loop to for-of loop.
Attachment #8561106 - Flags: review?(kyle)
Comment on attachment 8561106 [details] [diff] [review]
Webapps_ReferenceError.patch

Review of attachment 8561106 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm, thanks!
Attachment #8561106 - Flags: review?(kyle) → review+
Assignee: kyle → cpeterson
URL:
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/8b46de889f4c
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.