Firefox cannot upload folders to Amazon CloudDrive (DataTransfer.items and item.getAsEntry() missing)

RESOLVED DUPLICATE of bug 876480

Status

()

RESOLVED DUPLICATE of bug 876480
4 years ago
4 years ago

People

(Reporter: gen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8517139 [details]
Screen Shot 2014-11-05 at 11.14.20 AM.png

Sign into Amazon CloudDrive. Select a folder to upload. CloudDrive tells Firefox user to use Chrome as Firefox cannot upload folders.

Firefox should be able to upload folders to Amazon CloudDrive.
Is this Amazon making an assumption about Firefox or Firefox not supporting an API required for the upload?
Flags: needinfo?(overholt)
Flags: needinfo?(hsteen)
Flags: firefox-backlog?
Supported in Chrome for a while:
http://updates.html5rocks.com/2012/07/Drag-and-drop-a-folder-onto-Chrome-now-available

Firefox doesn't even have DataTransfer.items - https://bugzilla.mozilla.org/show_bug.cgi?id=906420 
So even though somebody claims to have solved the problem on SO http://stackoverflow.com/questions/12612237/how-can-you-detect-that-a-user-dragged-a-folder-not-a-file-into-their-browser
it's not really a solution to the "upload all files in a folder" problem.

See also http://filedropjs.org/demo/#dir 
"Supported only in Chrome 21+. W3C has a working draft on File System API that introduces lots of interesting features allowing us to read and write files and directories."

Their code includes:

    self.setNativeEntry = function (item) {
      self.nativeEntry = item && item.webkitGetAsEntry && item.webkitGetAsEntry()
    }

But the W3C spec they link to is pretty much empty (?!?) http://www.w3.org/TR/file-system-api/
Flags: needinfo?(hsteen)
I'm pretty sure we'll have other open bugs.. guess 876480 is the real master
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 906420
Resolution: --- → DUPLICATE
Summary: Firefox cannot upload folders to Amazon CloudDrive → Firefox cannot upload folders to Amazon CloudDrive (DataTransfer.items and item.getAsEntry() missing)
Duplicate of bug: 876480
Flags: needinfo?(overholt)
Google's file system API has been abandoned.
http://www.w3.org/TR/file-system-api/
"Work on this document has been discontinued and it should not be referenced or used as a basis for implementation."

WhatWG spec doesn't seem to talk anything about directories. Just Dnd multiple files should be supported.
(In reply to Olli Pettay [:smaug] from comment #4)
> Google's file system API has been abandoned.

Too bad there's advice out there recommending using it and sites that apparently rely on it.. Seems the worst possible state for vendors but Google itself :(

Also, dragging and dropping a directory is a useful feature. Somebody should be working on such a spec..
I think sicking and arun have plans for a better file system api.
(In reply to Olli Pettay [:smaug] from comment #6)
> I think sicking and arun have plans for a better file system api.

Indeed:  http://w3c.github.io/filesystem-api/Overview.html
Flags: firefox-backlog?
You need to log in before you can comment on or make changes to this bug.