error C2065: 'device' :undeclared identifier

RESOLVED FIXED in Firefox 35

Status

()

--
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: ewong, Assigned: jrmuizel)

Tracking

({dogfood, regression})

unspecified
mozilla37
x86
Windows Vista
dogfood, regression
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox35 fixed, firefox36 fixed, firefox37 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
In both c-c's TB and SM Windows trunk build:

module.res
tdcache.c
Unified_cpp_angle_src_libGLESv20.cpp
d:\msvs10\vc\include\typeinfo(157) : warning C4275: non dll-interface class 'stdext::exception' used as base for dll-interface class 'std::bad_cast'
        d:\msvs10\vc\include\exception(218) : see declaration of 'stdext::exception'
        d:\msvs10\vc\include\typeinfo(156) : see declaration of 'std::bad_cast'
d:\msvs10\vc\include\typeinfo(178) : warning C4275: non dll-interface class 'stdext::exception' used as base for dll-interface class 'std::bad_typeid'
        d:\msvs10\vc\include\exception(218) : see declaration of 'stdext::exception'
        d:\msvs10\vc\include\typeinfo(177) : see declaration of 'std::bad_typeid'
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\common/NativeWindow.h(23) : error C2146: syntax error : missing ';' before identifier 'DXGISwapChain'
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\common/NativeWindow.h(23) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\common/NativeWindow.h(23) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\common/NativeWindow.h(24) : error C2146: syntax error : missing ';' before identifier 'DXGIFactory'
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\common/NativeWindow.h(24) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\common/NativeWindow.h(24) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\common/NativeWindow.h(40) : error C2061: syntax error : identifier 'ID3D11Device'
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\libGLESv2\../common/win32/NativeWindow.cpp(23) : error C2065: 'ID3D11Device' : undeclared identifier
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\libGLESv2\../common/win32/NativeWindow.cpp(23) : error C2065: 'device' : undeclared identifier
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\libGLESv2\../common/win32/NativeWindow.cpp(23) : error C2065: 'factory' : undeclared identifier
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\libGLESv2\../common/win32/NativeWindow.cpp(24) : error C2065: 'DXGI_FORMAT' : undeclared identifier
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\libGLESv2\../common/win32/NativeWindow.cpp(24) : error C2146: syntax error : missing ')' before identifier 'format'
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\libGLESv2\../common/win32/NativeWindow.cpp(24) : error C2761: 'HRESULT rx::NativeWindow::createSwapChain(void)' : member function redeclaration not allowed
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\libGLESv2\../common/win32/NativeWindow.cpp(25) : error C2059: syntax error : ')'
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\libGLESv2\../common/win32/NativeWindow.cpp(26) : error C2143: syntax error : missing ';' before '{'
e:\builds\slave\c-cen-t-w32\build\mozilla\gfx\angle\src\libGLESv2\../common/win32/NativeWindow.cpp(26) : error C2447: '{' : missing function header (old-style formal list?)
e:/builds/slave/c-cen-t-w32/build/mozilla/config/rules.mk:940: recipe for target 'Unified_cpp_angle_src_libGLESv20.obj' failed
mozmake.exe[4]: Leaving directory 'e:/builds/slave/c-cen-t-w32/build/objdir/gfx/angle/src/libGLESv2'
e:/builds/slave/c-cen-t-w32/build/mozilla/config/recurse.mk:74: recipe for target 'gfx/angle/src/libGLESv2/target' failed
e:/builds/slave/c-cen-t-w32/build/mozmake.exe -C e:/builds/slave/c-cen-t-w32/build/mozilla/security/nss/lib/nss/../dev libs  CC=' cl' SOURCE_MD_DIR=e:/builds/slave/c-cen-t-w32/build/objdir/dist SOURCE_MDHEADERS_DIR=e:/builds/slave/c-cen-t-w32/build/objdir/dist/include/nspr DIST=e:/builds/slave/c-cen-t-w32/build/objdir/dist NSPR_INCLUDE_DIR=e:/builds/slave/c-cen-t-w32/build/objdir/dist/include/nspr NSPR_LIB_DIR=e:/builds/slave/c-cen-t-w32/build/objdir/dist/lib MOZILLA_CLIENT=1 NO_MDUPDATE=1 NSS_ENABLE_ECC=1 SQLITE_LIB_NAME=nss3 SQLITE_INCLUDE_DIR=e:/builds/slave/c-cen-t-w32/build/objdir/dist/include topsrcdir='e:/builds/slave/c-cen-t-w32/build/mozilla' BUILD='e:/builds/slave/c-cen-t-w32/build/objdir/security/$(subst $(topsrcdir)/security/,,$(CURDIR))' BUILD_TREE='$(BUILD)' OBJDIR='$(BUILD)' DEPENDENCIES='$(BUILD)/.deps' SINGLE_SHLIB_DIR='$(BUILD)' SOURCE_XP_DIR=e:/builds/slave/c-cen-t-w32/build/objdir/dist BUILD_OPT=1 OPT_CODE_SIZE=1 NS_USE_GCC= OS_TARGET=WIN95 NSS_ENABLE_ZLIB= PROGRAMS= CHECKLOC= FREEBL_NO_DEPEND=0 NSS_NO_PKCS11_BYPASS=1 PUBLIC_EXPORT_DIR='e:/builds/slave/c-cen-t-w32/build/objdir/dist/include/$(MODULE)' SOURCE_XPHEADERS_DIR='$(SOURCE_XP_DIR)/include/$(MODULE)' MODULE_INCLUDES='$(addprefix -I$(SOURCE_XP_DIR)/include/,$(REQUIRES))' MAKE_OBJDIR='$(INSTALL) -D $(OBJDIR)' TARGETS='$(LIBRARY) $(SHARED_LIBRARY) $(PROGRAM)' PYTHON='e:/builds/slave/c-cen-t-w32/build/objdir/_virtualenv/Scripts/python.exe' NSINSTALL_PY='e:/builds/slave/c-cen-t-w32/build/mozilla/config/nsinstall.py' NSINSTALL='$(PYTHON) $(NSINSTALL_PY)' INSTALL='$(NSINSTALL) -t'  SHARED_LIBRARY= IMPORT_LIBRARY=
mozmake.exe[5]: Entering directory 'e:/builds/slave/c-cen-t-w32/build/mozilla/security/nss/lib/dev'
mozmake.exe[4]: *** [Unified_cpp_angle_src_libGLESv20.obj] Error 2
mozmake.exe[3]: *** [gfx/angle/src/libGLESv2/target] Error 2
mozmake.exe[3]: *** Waiting for unfinished jobs....
(Reporter)

Updated

4 years ago
Depends on: 1076020

Updated

4 years ago
Blocks: 1076020
Severity: normal → blocker
No longer depends on: 1076020
Keywords: dogfood, regression

Comment 1

4 years ago
Created attachment 8521388 [details] [diff] [review]
Possible patch
Attachment #8521388 - Flags: review?(jmuizelaar)
(Assignee)

Comment 2

4 years ago
Comment on attachment 8521388 [details] [diff] [review]
Possible patch

Review of attachment 8521388 [details] [diff] [review]:
-----------------------------------------------------------------

If this fixes things I'm happy to take it for now. Please let me or jgilbert land this through the mozilla/angle github repo
Attachment #8521388 - Flags: review?(jmuizelaar) → review+
This is currently busting SeaMonkey win aurora jobs at least.  When would this likely land for us there?
Flags: needinfo?(jmuizelaar)
(Assignee)

Comment 4

4 years ago
I'll try to land this on trunk today.
Flags: needinfo?(jmuizelaar)

Comment 5

4 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> I'll try to land this on trunk today.
Did this manage to land before uplift? Because if not we'll need this on mozilla-aurora.
Flags: needinfo?(jmuizelaar)
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1106899
(Reporter)

Comment 7

4 years ago
(In reply to Philip Chee from comment #5)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> > I'll try to land this on trunk today.
> Did this manage to land before uplift? Because if not we'll need this on
> mozilla-aurora.

Mozilla-beta as well as I'm seeing this in SeaMonkey win32 c-b builders.

Comment 8

4 years ago
Comment on attachment 8521388 [details] [diff] [review]
Possible patch

Approval Request Comment
[Feature/regressing bug #]: Bug 1076020 - Update ANGLE to get "Enable MRT pixel shader rewriting."
[User impact if declined]: no comm-aurora builds, no comm-beta builds for Thunderbird or SeaMonkey
[Describe test coverage new/current, TBPL]: no successful builds without this patch. Therefore no test coverage without this patch.
[Risks and why]: low to none risk, bustage fix. 
[String/UUID change made/needed]: none
Attachment #8521388 - Flags: approval-mozilla-beta?
Attachment #8521388 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d936c413e03b
Assignee: nobody → jmuizelaar
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 37.0
Attachment #8521388 - Flags: approval-mozilla-beta?
Attachment #8521388 - Flags: approval-mozilla-beta+
Attachment #8521388 - Flags: approval-mozilla-aurora?
Attachment #8521388 - Flags: approval-mozilla-aurora+
Component: Build Config → Graphics
Product: MailNews Core → Core
Target Milestone: Thunderbird 37.0 → mozilla37
https://hg.mozilla.org/releases/mozilla-aurora/rev/802533342580
https://hg.mozilla.org/releases/mozilla-beta/rev/dca84e64ef76
status-firefox35: --- → fixed
status-firefox36: --- → fixed
status-firefox37: --- → fixed
Flags: needinfo?(jmuizelaar)

Updated

4 years ago
Blocks: 1099556
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.