Japanese input, when followed by ASCII input, is erased

VERIFIED WORKSFORME

Status

defect
P2
major
VERIFIED WORKSFORME
20 years ago
3 years ago

People

(Reporter: momoi, Assigned: tague)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

** Observed with 7/30/99 Win32 M9 build **

1. Open a new mail compose window.
2. Turn on JPN IME and input some characters. Commit them.
3. Then tunr off the IME (LeftALT + `) and then start
   inputting ASCII characters. The moment you start doing
   this the previous characters are gone.

(If you begin with some ASCII input and then follow with
 step 2. The Japanese entry does not disappear in step 3.)
Chnaging QA contact to myself.
I tried both HTML and Plain Text Composer and this problem
does not occur under the same condition. The problem seems to
be limited to Mail composer.
Component: Composition → Necko
Priority: P3 → P2
Target Milestone: M9
This was working prior to Necko landing.
So, I'll mark this a Necko bug.
I believe that mscott wanted to get rid of the Necko component in MailNews
product.  Perhaps you can change the component to Internationalization (?)
Component: Necko → Composition
Changed the component to Composition.
We should track Necko i18n regression in a meta bug.
Status: NEW → ASSIGNED
Depends on: 10940
Adding dependency on other broken Japanese mail bug.
Target Milestone: M9 → M11
I'm moving this out a couple of milestones, since it's difficult to reproduce.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
** Re-checked with 8/13/99 Win32 build **

Iguess this was a few days wonder.
The problem no longer seems to occur with plain text
or HTML Mail composition.
I'll mark this Worksforme.
There is a dependency noted here for 10940, but I don't think
these 2 bugs are related.
No longer depends on: 10940
no, the two bugs aren't related.  i'm removing the dependency.  this should be
okay to close out.
Status: RESOLVED → VERIFIED
** Re-checked with 9/16/99 Win32 M11 build **

This problem does not occur with the above build, either.
Marking it Verified/Worksforme.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.