Closed Bug 1094746 Opened 5 years ago Closed 5 years ago

[Dialer][Call Screen] Remove horizontal line at the bottom of a conference participant list overlay

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 verified)

VERIFIED FIXED
2.1 S9 (21Nov)
Tracking Status
b2g-v2.2 --- verified

People

(Reporter: gtorodelvalle, Assigned: paco)

References

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(5 files)

The horizontal line at the bottom of the participant list overlay during a conference call should be removed. Please see the screenshot attached ;)
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Assignee: nobody → pacorampas
Depends on: 977056
Attached file patch in github
Attached image overlay-last-line.png
Attachment #8519871 - Flags: review?(drs.bugzilla)
Attachment #8519871 - Flags: review?(gtorodelvalle)
Whiteboard: [planned-sprint c=1]
Target Milestone: --- → 2.1 S9 (21Nov)
Comment on attachment 8519871 [details] [review]
patch in github

Redirecting to Germán.
Attachment #8519871 - Flags: review?(drs.bugzilla)
Hi Paco! Thank you very much ;) Simple patch fixing the issue :)

Anyhow, I noticed the /shared/style/dialer/overlay.css file is also linked by https://github.com/mozilla-b2g/gaia/blob/master/apps/default_theme/index.html#L19 so I am going to clarify this issue with Olle before setting the r+ ;)

Olle, I was just curious about the reason why the shared styles used by the Dialer - Call Screen - Emergency Call apps where included amongst the linked styles of the default theme in https://github.com/mozilla-b2g/gaia/commit/3ab1b18bbf409df4ac513d11d89133bdb16b6aaa since they are not building blocks and I highly doubt they are going to be themeable. As I said, just wondering about it since I may be wrong ;) Thanks!
Flags: needinfo?(olle.klang)
(In reply to Germán Toro del Valle from comment #4)

> Olle, I was just curious about the reason why the shared styles used by the
> Dialer - Call Screen - Emergency Call apps where included amongst the linked
> styles of the default theme in
> https://github.com/mozilla-b2g/gaia/commit/
> 3ab1b18bbf409df4ac513d11d89133bdb16b6aaa since they are not building blocks
> and I highly doubt they are going to be themeable. As I said, just wondering
> about it since I may be wrong ;) Thanks!

Hi Germán!

The default theme is actually a bit outdated and none of the linked shared styles are used. I'll post a bug to update this. In other words, the suggested patch has no effect on theming. 

(Sorry for the late response, I'm on parental leave).
Flags: needinfo?(olle.klang)
Comment on attachment 8519871 [details] [review]
patch in github

Ups! Sorry for bothering, enjoy our parental leave and thank you very much for your response ;)

Paco, according to comment 5 we are ready to merge ;) Thanks!
Attachment #8519871 - Flags: review?(gtorodelvalle) → review+
BTW, Paco and just not to forget about it ;) Would you be so kind to include a demo of this patch at https://wiki.mozilla.org/FirefoxOS/Comms/Dialer/Sprint/v2.1-S9#Demos , please ? Thank you very much!
Flags: needinfo?(pacorampas)
Flags: needinfo?(pacorampas)
I went ahead and merged this.

https://github.com/mozilla-b2g/gaia/commit/0653faa86993825af3903f1706fee88635f861f8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attached image Verify1_Flame_v2.2.png
This bug has been verified as pass on latest build of Flame v2.2.

STR:
1.Launch dialer app.
2.Make a phone call like 10010.
3.Tap the '+' button.
4.Make a phone call again.
5.Tap the up arrow button.
6.Tap "Conference" at the top. 

Actual result: No horizontal line displays at the bottom of the participant list.

See attachment:Verify1_Flame_v2.2

Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150715002506
Gaia Revision          84d0c76370dcd3d25813b00de55194730884355b
Gaia Date              2015-07-09 13:09:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a5db6d9850f6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150715.040736
Firmware Date          Wed Jul 15 04:07:49 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.